summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-06-26 16:47:30 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-06-26 16:53:06 -0400
commit9c149927265b8817be0093b8c3ac5cc5bf36efb2 (patch)
tree8e95763c4f490e7a3ba388274502a92a9758141c /sys-fs/ntfs3g/ntfs3g-2017.3.23-r1.ebuild
parentapp-admin/testdisk: fix qa warning and subslot dep on ntfs3g (diff)
downloadgentoo-9c149927265b8817be0093b8c3ac5cc5bf36efb2.tar.gz
gentoo-9c149927265b8817be0093b8c3ac5cc5bf36efb2.tar.bz2
gentoo-9c149927265b8817be0093b8c3ac5cc5bf36efb2.zip
sys-fs/ntfs3g: fix subslot and qa warnings
the qa warning easily help simplify the deps, fuse 3 is slot 3 so no need for ugly deps Package-Manager: Portage-2.3.40, Repoman-2.3.9 RepoMan-Options: --force
Diffstat (limited to 'sys-fs/ntfs3g/ntfs3g-2017.3.23-r1.ebuild')
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2017.3.23-r1.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/sys-fs/ntfs3g/ntfs3g-2017.3.23-r1.ebuild b/sys-fs/ntfs3g/ntfs3g-2017.3.23-r1.ebuild
new file mode 100644
index 000000000000..8b217b0ad54b
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-2017.3.23-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils linux-info udev toolchain-funcs libtool
+
+MY_PN=${PN/3g/-3g}
+MY_P=${MY_PN}_ntfsprogs-${PV}
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
+SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+# The subslot matches the SONAME major #.
+SLOT="0/88"
+KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="acl debug +external-fuse ntfsdecrypt +ntfsprogs static-libs suid xattr"
+
+RDEPEND="!<sys-apps/util-linux-2.20.1-r2
+ !sys-fs/ntfsprogs
+ ntfsdecrypt? (
+ >=dev-libs/libgcrypt-1.2.2:0
+ >=net-libs/gnutls-1.4.4
+ )
+ external-fuse? (
+ >=sys-fs/fuse-2.8.0:0
+ )"
+DEPEND="${RDEPEND}
+ sys-apps/attr
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS ChangeLog CREDITS README"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2014.2.15-no-split-usr.patch
+ "${FILESDIR}"/${PN}-2016.2.22-sysmacros.patch #580136
+)
+
+pkg_setup() {
+ if use external-fuse && use kernel_linux; then
+ if kernel_is lt 2 6 9; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use ntfs-3g"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ # Keep the symlinks in the same place we put the main binaries.
+ # Having them in / when all the progs are in /usr is pointless.
+ sed -i \
+ -e 's:/sbin:$(sbindir):g' \
+ {ntfsprogs,src}/Makefile.in || die #578336
+ # Note: patches apply to Makefile.in, so don't run autotools here.
+ elibtoolize
+}
+
+src_configure() {
+ tc-ld-disable-gold
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}"/usr \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ --enable-ldscript \
+ --disable-ldconfig \
+ $(use_enable acl posix-acls) \
+ $(use_enable xattr xattr-mappings) \
+ $(use_enable ntfsdecrypt crypto) \
+ $(use_enable ntfsprogs) \
+ $(use_enable ntfsprogs quarantined) \
+ --without-uuid \
+ --enable-extras \
+ $(use_enable static-libs static) \
+ --with-fuse=$(usex external-fuse external internal)
+}
+
+src_install() {
+ default
+
+ use suid && fperms u+s /usr/bin/${MY_PN}
+ udev_dorules "${FILESDIR}"/99-ntfs3g.rules
+ prune_libtool_files
+
+ dosym mount.ntfs-3g /usr/sbin/mount.ntfs #374197
+}