summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Gerstner <Matthias.Gerstner@nefkom.net>2021-04-10 13:13:03 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-04-13 13:38:05 +0300
commitb16dda6c19de9bc11e36e417625a116b5616d0f7 (patch)
treeb8cf6cfd845cafcf80ba976b59f3b36e1924fbb7 /sys-fs/xwmfs
parentnet-analyzer/greenbone-security-assistant: fix nodejs dependency (diff)
downloadgentoo-b16dda6c19de9bc11e36e417625a116b5616d0f7.tar.gz
gentoo-b16dda6c19de9bc11e36e417625a116b5616d0f7.tar.bz2
gentoo-b16dda6c19de9bc11e36e417625a116b5616d0f7.zip
sys-fs/xwmfs: version bump to 0.90
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Matthias Gerstner <matthias.gerstner@nefkom.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs/xwmfs')
-rw-r--r--sys-fs/xwmfs/Manifest1
-rw-r--r--sys-fs/xwmfs/xwmfs-0.90.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sys-fs/xwmfs/Manifest b/sys-fs/xwmfs/Manifest
index d1437e65e48a..894a237684f2 100644
--- a/sys-fs/xwmfs/Manifest
+++ b/sys-fs/xwmfs/Manifest
@@ -1 +1,2 @@
DIST xwmfs-0.86.tar.gz 195544 BLAKE2B 7dc5eb4d7acd585be70c43142b1a093aefecd69d8c51f6dee1741e88ab0c592d195678df107c28426d4eab18ae3d33b292cb0b8ab9c5ab557e1c81d3e557c492 SHA512 2f053c8e7322af39f46c85c46c11c5d215b7797d0ccb8340ba143371f3a5b171cac324936a0559fc3bd1cad0aed31c02576ad71b269052e3d01fb7b896bd1a81
+DIST xwmfs-0.90.tar.gz 199555 BLAKE2B b2223edb1befad1055d103c03ba8092ea6319eb7299ec9e74338567aef9e45071f056ebfaddd41bcca3722f2ad96122d5009890847b6a485ea700e1e43d2893b SHA512 70805bc509cd8ab11d75b0f9b303f76c6e7c0af7664eca4f9f1dc14c6d59d34a1bcf3e1ffde427b7f11740f1b52e7838c44a28de44fd96ca0bacb45c8b160a67
diff --git a/sys-fs/xwmfs/xwmfs-0.90.ebuild b/sys-fs/xwmfs/xwmfs-0.90.ebuild
new file mode 100644
index 000000000000..6f9d03e0f508
--- /dev/null
+++ b/sys-fs/xwmfs/xwmfs-0.90.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="FUSE-based X11 Window-Manager file system"
+HOMEPAGE="https://github.com/gerstner-hub/xwmfs"
+SRC_URI="https://github.com/gerstner-hub/${PN}/releases/download/v${PV}/${P}-dist.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+
+RDEPEND="
+ sys-fs/fuse:0=
+ >=x11-libs/libX11-1.6.5"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_test() {
+ # unset display to avoid testing errors, tests rely on X11 and a window
+ # manager environment
+ unset DISPLAY
+
+ default
+}