summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-05-12 15:27:58 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-05-12 15:42:06 -0700
commit6abc4b173f308b319f6cdf81eaf7d3a698575082 (patch)
tree502b6483a0f6c487eb4981a80dcae3b3f8fbf248 /sys-fs/zfs
parentsys-fs/zfs-kmod: sync changes from live ebuild to 0.8.4 (diff)
downloadgentoo-6abc4b173f308b319f6cdf81eaf7d3a698575082.tar.gz
gentoo-6abc4b173f308b319f6cdf81eaf7d3a698575082.tar.bz2
gentoo-6abc4b173f308b319f6cdf81eaf7d3a698575082.zip
sys-fs/zfs: sync changes from live ebuild to 0.8.4
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-fs/zfs')
-rw-r--r--sys-fs/zfs/zfs-0.8.4.ebuild21
1 files changed, 6 insertions, 15 deletions
diff --git a/sys-fs/zfs/zfs-0.8.4.ebuild b/sys-fs/zfs/zfs-0.8.4.ebuild
index 3fbc4b3ebd11..c7cc180b9ea0 100644
--- a/sys-fs/zfs/zfs-0.8.4.ebuild
+++ b/sys-fs/zfs/zfs-0.8.4.ebuild
@@ -6,16 +6,16 @@ EAPI=7
DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{6,7} )
-inherit bash-completion-r1 flag-o-matic linux-info distutils-r1 systemd toolchain-funcs udev usr-ldscript
+inherit autotools bash-completion-r1 flag-o-matic linux-info distutils-r1 systemd toolchain-funcs udev usr-ldscript
DESCRIPTION="Userland utilities for ZFS Linux kernel module"
-HOMEPAGE="https://zfsonlinux.org/"
+HOMEPAGE="https://github.com/openzfs/zfs"
if [[ ${PV} == "9999" ]] ; then
- inherit autotools git-r3 linux-mod
- EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
+ inherit git-r3 linux-mod
+ EGIT_REPO_URI="https://github.com/openzfs/zfs.git"
else
- SRC_URI="https://github.com/zfsonlinux/${PN}/releases/download/${P}/${P}.tar.gz"
+ SRC_URI="https://github.com/openzfs/${PN}/releases/download/${P}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64"
fi
@@ -68,9 +68,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="test"
-PATCHES=(
- "${FILESDIR}/bash-completion-sudo.patch"
-)
+PATCHES=( "${FILESDIR}/bash-completion-sudo.patch" )
pkg_setup() {
if use kernel_linux && use test-suite; then
@@ -176,7 +174,6 @@ src_install() {
# enforce best available python implementation
python_fix_shebang "${ED}/bin"
-
}
pkg_postinst() {
@@ -187,12 +184,6 @@ pkg_postinst() {
elog " sys-kernel/dracut"
elog " sys-kernel/genkernel"
fi
-
- if has_version "<=sys-kernel/genkernel-3.5.3.3"; then
- einfo "genkernel version 3.5.3.3 and earlier does NOT support"
- einfo " unlocking pools with native zfs encryption enabled at boot"
- einfo " use dracut or >=genkernel-4 if you requre this functionality"
- fi
fi
if ! use kernel-builtin && [[ ${PV} = "9999" ]]; then