summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-13 21:14:23 +0000
committerSam James <sam@gentoo.org>2023-03-13 21:14:23 +0000
commit259afa056e0f327d7914ed0f15f623c908afca15 (patch)
tree46de196a527f253f881486851da67db8b67e41b6 /sys-fs
parentsys-fs/exfat-utils: add 1.4.0 (diff)
downloadgentoo-259afa056e0f327d7914ed0f15f623c908afca15.tar.gz
gentoo-259afa056e0f327d7914ed0f15f623c908afca15.tar.bz2
gentoo-259afa056e0f327d7914ed0f15f623c908afca15.zip
sys-fs/fuse-exfat: add 1.4.0
Bug: https://bugs.gentoo.org/842213 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse-exfat/Manifest1
-rw-r--r--sys-fs/fuse-exfat/fuse-exfat-1.4.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/sys-fs/fuse-exfat/Manifest b/sys-fs/fuse-exfat/Manifest
index e5b775c98d04..e6075aaa0a50 100644
--- a/sys-fs/fuse-exfat/Manifest
+++ b/sys-fs/fuse-exfat/Manifest
@@ -1 +1,2 @@
DIST fuse-exfat-1.3.0.tar.gz 161278 BLAKE2B 864eed57d5ae70eac03464899ac7c63f5d55254b61b69064592bb7ae04f6c164b8113c568946103c407867c1b53511bf2b88bd6b25cf75aa3a1a9a2a7d4f12ae SHA512 90d2b89322590199012b035b88ae01559f1824172793d9e7845603940e2807e788c687e4958f1ef76678bd214bb03671b91fd2537901b6d6acf2e8c525a3f1f3
+DIST fuse-exfat-1.4.0.tar.gz 167536 BLAKE2B b277a6cce725d5dde83fe8ebba9cb2899cf41bfbb600f0044e45da9af06681b5fe7440456a73865739e4bcca525f33de06aedc8935d0de88d7d8a37dc1123fc6 SHA512 9285d17786cdbb50f531a7f35795dbf3b650b33c6fd81619174791516c0ef5743fb6450d1d898900cfc142c088eccf8fc44ea1ccbbe1af07e2cbd1d65c73a174
diff --git a/sys-fs/fuse-exfat/fuse-exfat-1.4.0.ebuild b/sys-fs/fuse-exfat/fuse-exfat-1.4.0.ebuild
new file mode 100644
index 000000000000..7bbae4d83889
--- /dev/null
+++ b/sys-fs/fuse-exfat/fuse-exfat-1.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="exFAT filesystem FUSE module"
+HOMEPAGE="https://github.com/relan/exfat"
+SRC_URI="https://github.com/relan/exfat/releases/download/v${PV}/${P}.tar.gz"
+
+# COPYING is GPL-2 but ChangeLog says "Relicensed the project from GPLv3+ to GPLv2+"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="suid"
+
+RDEPEND="sys-fs/fuse:3"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_install() {
+ default
+ use suid && fperms u+s /usr/sbin/mount.exfat-fuse
+ dosym mount.exfat-fuse.8 /usr/share/man/man8/mount.exfat.8
+}