summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2024-07-30 02:40:44 +0200
committerJakov Smolić <jsmolic@gentoo.org>2024-07-31 01:44:03 +0200
commit91ab1e52adbb26c00f28aab8f836e5089118c625 (patch)
treef95ba2f7629b6d37f47a0e05b335d794d3fcb0d7 /sys-fs
parentdev-libs/libjodycode: add 3.1.1 (diff)
downloadgentoo-91ab1e52adbb26c00f28aab8f836e5089118c625.tar.gz
gentoo-91ab1e52adbb26c00f28aab8f836e5089118c625.tar.bz2
gentoo-91ab1e52adbb26c00f28aab8f836e5089118c625.zip
sys-fs/clamfs: Bump to 1.3.0
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/clamfs/Manifest1
-rw-r--r--sys-fs/clamfs/clamfs-1.3.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/clamfs/Manifest b/sys-fs/clamfs/Manifest
index 5a124afde67a..59ddc6b49069 100644
--- a/sys-fs/clamfs/Manifest
+++ b/sys-fs/clamfs/Manifest
@@ -1 +1,2 @@
DIST clamfs-1.2.0.tar.gz 196903 BLAKE2B aa84e3a35714a2638d9569b6bb77f5da5c34f962d7baff0e5b08bbd7a56f1d1624936a5054b1a99d5593dc20412e55f36ab732fb84326f40c0614f084698618f SHA512 72a8625c18f520258075cb0310d14974e15f7f0cd628ca968317adac778fd8db26fa28bd72d954f2c21e6c41c32a38a5fbfa8be3918f9e0314d1d7f1da2cc626
+DIST clamfs-1.3.0.tar.gz 229989 BLAKE2B 05327d8b6fbe7073c5bd70104282a32009f06556fd61267931f4d841378318e29bb1fc7157da6b5ebce80dda35484f5bc2af71fcecdb3739a4dd28507c767054 SHA512 81c234ec631abd49d9a6b940ef727a1eae048b7be12be6082ec176ed4045fcd92d35d1264e7fd48906786af7c07696139fd5bfa0a302fba7ebb2c528315857a1
diff --git a/sys-fs/clamfs/clamfs-1.3.0.ebuild b/sys-fs/clamfs/clamfs-1.3.0.ebuild
new file mode 100644
index 000000000000..11936b72211f
--- /dev/null
+++ b/sys-fs/clamfs/clamfs-1.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools linux-info
+
+DESCRIPTION="A FUSE-based user-space file system with on-access anti-virus file scanning"
+HOMEPAGE="https://github.com/burghardt/clamfs"
+SRC_URI="https://github.com/burghardt/clamfs/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/boost
+ dev-libs/poco
+ dev-libs/rlog
+ sys-fs/fuse:3"
+RDEPEND="${DEPEND}
+ app-antivirus/clamav"
+
+CONFIG_CHECK="~FUSE_FS"
+
+src_prepare() {
+ # Do not use Werror ( #754180 )
+ sed -i 's/\-Werror//g' configure.ac || die "Sed failed"
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ insinto /etc/clamfs
+ doins doc/clamfs.xml
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}