summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-12-23 18:20:19 -0500
committerMike Gilbert <floppym@gentoo.org>2022-12-23 18:21:20 -0500
commit9343c4b2c895f8fa3812a4aebebf5ead1a5db609 (patch)
tree4f7b92c8ba534f63fb45e9575a6c6dc76f9c3020 /sys-kernel/dracut
parentwww-client/vivaldi: Make GTK optional and add Qt5 support (diff)
downloadgentoo-9343c4b2c895f8fa3812a4aebebf5ead1a5db609.tar.gz
gentoo-9343c4b2c895f8fa3812a4aebebf5ead1a5db609.tar.bz2
gentoo-9343c4b2c895f8fa3812a4aebebf5ead1a5db609.zip
sys-kernel/dracut: drop 055-r4, 056, 056-r2
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-kernel/dracut')
-rw-r--r--sys-kernel/dracut/Manifest2
-rw-r--r--sys-kernel/dracut/dracut-055-r4.ebuild178
-rw-r--r--sys-kernel/dracut/dracut-056-r2.ebuild176
-rw-r--r--sys-kernel/dracut/dracut-056.ebuild174
-rw-r--r--sys-kernel/dracut/files/055-add-blockfuncs.patch25
-rw-r--r--sys-kernel/dracut/files/055-fix-base-do-not-quote-initargs-for-switch_root.patch32
-rw-r--r--sys-kernel/dracut/files/055-fix-crypt-remove-quotes-from-cryptsetupopts.patch39
-rw-r--r--sys-kernel/dracut/files/055-fix-usrmount-do-not-empty-_dev-variable.patch36
-rw-r--r--sys-kernel/dracut/files/055-tpm2-tss-typo.patch23
-rw-r--r--sys-kernel/dracut/files/056-fix-lvm-add-missing-grep-requirement.patch36
-rw-r--r--sys-kernel/dracut/files/056-musl.patch33
11 files changed, 0 insertions, 754 deletions
diff --git a/sys-kernel/dracut/Manifest b/sys-kernel/dracut/Manifest
index b62dc908356f..85f48f8a238f 100644
--- a/sys-kernel/dracut/Manifest
+++ b/sys-kernel/dracut/Manifest
@@ -1,3 +1 @@
-DIST dracut-055.tar.xz 361752 BLAKE2B 9fcb0bce9ead2e079c70a377ea53701e4634d3dc64ae163e0e157d7d85822a274813e05f6079768640e1807818fad7a8158626413d773686a8d52fcd95fb5680 SHA512 2d2ea2889d9013bc94245bd7d1a2154f24d02bd9c2f7dbb28e5968e17d918e6598c68d85b0f551f968218980a80b19361ca0c9e8e94997ba54f4c09afcd6d866
-DIST dracut-056.tar.xz 384196 BLAKE2B e3e4fa3024b401cc954ba6069c54e95912691ff68a838e3c43bfc6a5b284bdee1669c782b30503c0246b7146c545ee8825febefcff93bae76ec46067cb7b87e1 SHA512 19268763e128984d20cab766bbdf2de12fe534ce2562fc688203099ef9b4cf83d0ccd2129499c70cdc6dd4ad53f0ffc2f3378eff5b8a15fda27c23b20f903df2
DIST dracut-057.tar.gz 481345 BLAKE2B dcf663a1955753256866e9dfa318b0b46a132ea39223ab634d72af1611f7db394c23c1bb4326979a5ee919df6ce3b107c955c9c77ce1ec4f99de835352932901 SHA512 8acdc8db2233a9abbaeea218cc5b1be68c4985088995f42624750783f8d40ecbb7fa97ab4f6468f67c079c8418590ace317c143a92d9305640b48c7c0edd4089
diff --git a/sys-kernel/dracut/dracut-055-r4.ebuild b/sys-kernel/dracut/dracut-055-r4.ebuild
deleted file mode 100644
index 51c5114175d3..000000000000
--- a/sys-kernel/dracut/dracut-055-r4.ebuild
+++ /dev/null
@@ -1,178 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 linux-info optfeature systemd toolchain-funcs
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dracutdevs/dracut"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
- SRC_URI="https://www.kernel.org/pub/linux/utils/boot/${PN}/${P}.tar.xz"
-fi
-
-DESCRIPTION="Generic initramfs generation tool"
-HOMEPAGE="https://dracut.wiki.kernel.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="selinux test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-arch/cpio
- >=app-shells/bash-4.0:0
- sys-apps/coreutils[xattr(-)]
- >=sys-apps/kmod-23[tools]
- || (
- >=sys-apps/sysvinit-2.87-r3
- sys-apps/openrc[sysv-utils(-),selinux?]
- sys-apps/systemd[sysv-utils]
- )
- >=sys-apps/util-linux-2.21
- virtual/pkgconfig
- virtual/udev
-
- elibc_musl? ( sys-libs/fts-standalone )
- selinux? (
- sec-policy/selinux-dracut
- sys-libs/libselinux
- sys-libs/libsepol
- )
-"
-DEPEND="
- >=sys-apps/kmod-23
- elibc_musl? ( sys-libs/fts-standalone )
-"
-
-BDEPEND="
- app-text/asciidoc
- app-text/docbook-xml-dtd:4.5
- >=app-text/docbook-xsl-stylesheets-1.75.2
- >=dev-libs/libxslt-1.1.26
- virtual/pkgconfig
-"
-
-QA_MULTILIB_PATHS="usr/lib/dracut/.*"
-
-PATCHES=(
- "${FILESDIR}"/055-fix-crypt-remove-quotes-from-cryptsetupopts.patch
- "${FILESDIR}"/055-fix-base-do-not-quote-initargs-for-switch_root.patch
- "${FILESDIR}"/055-fix-usrmount-do-not-empty-_dev-variable.patch
- "${FILESDIR}"/055-tpm2-tss-typo.patch
- "${FILESDIR}"/055-add-blockfuncs.patch
- "${FILESDIR}"/gentoo-ldconfig-paths-r1.patch
-)
-
-src_configure() {
- local myconf=(
- --prefix="${EPREFIX}/usr"
- --sysconfdir="${EPREFIX}/etc"
- --bashcompletiondir="$(get_bashcompdir)"
- --systemdsystemunitdir="$(systemd_get_systemunitdir)"
- )
-
- tc-export CC PKG_CONFIG
-
- echo ./configure "${myconf[@]}"
- ./configure "${myconf[@]}" || die
-
- if [[ ${PV} != 9999 && ! -f dracut-version.sh ]] ; then
- # Source tarball from github doesn't include this file
- echo "DRACUT_VERSION=${PV}" > dracut-version.sh || die
- fi
-}
-
-src_test() {
- if [[ ${EUID} != 0 ]]; then
- # Tests need root privileges, bug #298014
- ewarn "Skipping tests: Not running as root."
- elif [[ ! -w /dev/kvm ]]; then
- ewarn "Skipping tests: Unable to access /dev/kvm."
- else
- emake -C test check
- fi
-}
-
-src_install() {
- local DOCS=(
- AUTHORS
- NEWS.md
- README.md
- docs/README.cross
- docs/README.generic
- docs/README.kernel
- docs/SECURITY.md
- )
-
- default
-
- docinto html
- dodoc dracut.html
-}
-
-pkg_postinst() {
- if linux-info_get_any_version && linux_config_exists; then
- ewarn ""
- ewarn "If the following test report contains a missing kernel"
- ewarn "configuration option, you should reconfigure and rebuild your"
- ewarn "kernel before booting image generated with this Dracut version."
- ewarn ""
-
- local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS"
-
- # Kernel configuration options descriptions:
- local ERROR_DEVTMPFS='CONFIG_DEVTMPFS: "Maintain a devtmpfs filesystem to mount at /dev" '
- ERROR_DEVTMPFS+='is missing and REQUIRED'
- local ERROR_BLK_DEV_INITRD='CONFIG_BLK_DEV_INITRD: "Initial RAM filesystem and RAM disk '
- ERROR_BLK_DEV_INITRD+='(initramfs/initrd) support" is missing and REQUIRED'
-
- check_extra_config
- echo
- else
- ewarn ""
- ewarn "Your kernel configuration couldn't be checked."
- ewarn "Please check manually if following options are enabled:"
- ewarn ""
- ewarn " CONFIG_BLK_DEV_INITRD"
- ewarn " CONFIG_DEVTMPFS"
- ewarn ""
- fi
-
- optfeature "Networking support" net-misc/networkmanager
- optfeature "Legacy networking support" net-misc/curl "net-misc/dhcp[client]" \
- sys-apps/iproute2 "net-misc/iputils[arping]"
- optfeature \
- "Measure performance of the boot process for later visualisation" \
- app-benchmarks/bootchart2 app-admin/killproc sys-process/acct
- optfeature "Scan for Btrfs on block devices" sys-fs/btrfs-progs
- optfeature "Load kernel modules and drop this privilege for real init" \
- sys-libs/libcap
- optfeature "Support CIFS" net-fs/cifs-utils
- optfeature "Decrypt devices encrypted with cryptsetup/LUKS" \
- "sys-fs/cryptsetup[-static-libs]"
- optfeature "Support for GPG-encrypted keys for crypt module" \
- app-crypt/gnupg
- optfeature \
- "Allows use of dash instead of default bash (on your own risk)" \
- app-shells/dash
- optfeature "Support iSCSI" sys-block/open-iscsi
- optfeature "Support Logical Volume Manager" sys-fs/lvm2
- optfeature "Support MD devices, also known as software RAID devices" \
- sys-fs/mdadm
- optfeature "Support Device Mapper multipathing" sys-fs/multipath-tools
- optfeature "Plymouth boot splash" '>=sys-boot/plymouth-0.8.5-r5'
- optfeature "Support network block devices" sys-block/nbd
- optfeature "Support NFS" net-fs/nfs-utils net-nds/rpcbind
- optfeature \
- "Install ssh and scp along with config files and specified keys" \
- net-misc/openssh
- optfeature "Enable logging with rsyslog" app-admin/rsyslog
- optfeature \
- "Enable rngd service to help generating entropy early during boot" \
- sys-apps/rng-tools
-}
diff --git a/sys-kernel/dracut/dracut-056-r2.ebuild b/sys-kernel/dracut/dracut-056-r2.ebuild
deleted file mode 100644
index 608284d33398..000000000000
--- a/sys-kernel/dracut/dracut-056-r2.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 linux-info optfeature systemd toolchain-funcs
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dracutdevs/dracut"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
- SRC_URI="https://www.kernel.org/pub/linux/utils/boot/${PN}/${P}.tar.xz"
-fi
-
-DESCRIPTION="Generic initramfs generation tool"
-HOMEPAGE="https://dracut.wiki.kernel.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="selinux test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-arch/cpio
- >=app-shells/bash-4.0:0
- sys-apps/coreutils[xattr(-)]
- >=sys-apps/kmod-23[tools]
- || (
- >=sys-apps/sysvinit-2.87-r3
- sys-apps/openrc[sysv-utils(-),selinux?]
- sys-apps/systemd[sysv-utils]
- sys-apps/s6-linux-init[sysv-utils(-)]
- )
- >=sys-apps/util-linux-2.21
- virtual/pkgconfig
- virtual/udev
-
- elibc_musl? ( sys-libs/fts-standalone )
- selinux? (
- sec-policy/selinux-dracut
- sys-libs/libselinux
- sys-libs/libsepol
- )
-"
-DEPEND="
- >=sys-apps/kmod-23
- elibc_musl? ( sys-libs/fts-standalone )
-"
-
-BDEPEND="
- app-text/asciidoc
- app-text/docbook-xml-dtd:4.5
- >=app-text/docbook-xsl-stylesheets-1.75.2
- >=dev-libs/libxslt-1.1.26
- virtual/pkgconfig
-"
-
-QA_MULTILIB_PATHS="usr/lib/dracut/.*"
-
-PATCHES=(
- "${FILESDIR}"/gentoo-ldconfig-paths-r1.patch
- "${FILESDIR}"/056-musl.patch
- "${FILESDIR}"/056-fix-lvm-add-missing-grep-requirement.patch
-)
-
-src_configure() {
- local myconf=(
- --prefix="${EPREFIX}/usr"
- --sysconfdir="${EPREFIX}/etc"
- --bashcompletiondir="$(get_bashcompdir)"
- --systemdsystemunitdir="$(systemd_get_systemunitdir)"
- )
-
- tc-export CC PKG_CONFIG
-
- echo ./configure "${myconf[@]}"
- ./configure "${myconf[@]}" || die
-
- if [[ ${PV} != 9999 && ! -f dracut-version.sh ]] ; then
- # Source tarball from github doesn't include this file
- echo "DRACUT_VERSION=${PV}" > dracut-version.sh || die
- fi
-}
-
-src_test() {
- if [[ ${EUID} != 0 ]]; then
- # Tests need root privileges, bug #298014
- ewarn "Skipping tests: Not running as root."
- elif [[ ! -w /dev/kvm ]]; then
- ewarn "Skipping tests: Unable to access /dev/kvm."
- else
- emake -C test check
- fi
-}
-
-src_install() {
- local DOCS=(
- AUTHORS
- NEWS.md
- README.md
- docs/README.cross
- docs/README.generic
- docs/README.kernel
- docs/SECURITY.md
- )
-
- default
-
- docinto html
- dodoc dracut.html
-}
-
-pkg_postinst() {
- if linux-info_get_any_version && linux_config_exists; then
- ewarn ""
- ewarn "If the following test report contains a missing kernel"
- ewarn "configuration option, you should reconfigure and rebuild your"
- ewarn "kernel before booting image generated with this Dracut version."
- ewarn ""
-
- local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS"
-
- # Kernel configuration options descriptions:
- local ERROR_DEVTMPFS='CONFIG_DEVTMPFS: "Maintain a devtmpfs filesystem to mount at /dev" '
- ERROR_DEVTMPFS+='is missing and REQUIRED'
- local ERROR_BLK_DEV_INITRD='CONFIG_BLK_DEV_INITRD: "Initial RAM filesystem and RAM disk '
- ERROR_BLK_DEV_INITRD+='(initramfs/initrd) support" is missing and REQUIRED'
-
- check_extra_config
- echo
- else
- ewarn ""
- ewarn "Your kernel configuration couldn't be checked."
- ewarn "Please check manually if following options are enabled:"
- ewarn ""
- ewarn " CONFIG_BLK_DEV_INITRD"
- ewarn " CONFIG_DEVTMPFS"
- ewarn ""
- fi
-
- optfeature "Networking support" net-misc/networkmanager
- optfeature "Legacy networking support" net-misc/curl "net-misc/dhcp[client]" \
- sys-apps/iproute2 "net-misc/iputils[arping]"
- optfeature \
- "Measure performance of the boot process for later visualisation" \
- app-benchmarks/bootchart2 app-admin/killproc sys-process/acct
- optfeature "Scan for Btrfs on block devices" sys-fs/btrfs-progs
- optfeature "Load kernel modules and drop this privilege for real init" \
- sys-libs/libcap
- optfeature "Support CIFS" net-fs/cifs-utils
- optfeature "Decrypt devices encrypted with cryptsetup/LUKS" \
- "sys-fs/cryptsetup[-static-libs]"
- optfeature "Support for GPG-encrypted keys for crypt module" \
- app-crypt/gnupg
- optfeature \
- "Allows use of dash instead of default bash (on your own risk)" \
- app-shells/dash
- optfeature "Support iSCSI" sys-block/open-iscsi
- optfeature "Support Logical Volume Manager" sys-fs/lvm2
- optfeature "Support MD devices, also known as software RAID devices" \
- sys-fs/mdadm
- optfeature "Support Device Mapper multipathing" sys-fs/multipath-tools
- optfeature "Plymouth boot splash" '>=sys-boot/plymouth-0.8.5-r5'
- optfeature "Support network block devices" sys-block/nbd
- optfeature "Support NFS" net-fs/nfs-utils net-nds/rpcbind
- optfeature \
- "Install ssh and scp along with config files and specified keys" \
- net-misc/openssh
- optfeature "Enable logging with rsyslog" app-admin/rsyslog
- optfeature \
- "Enable rngd service to help generating entropy early during boot" \
- sys-apps/rng-tools
-}
diff --git a/sys-kernel/dracut/dracut-056.ebuild b/sys-kernel/dracut/dracut-056.ebuild
deleted file mode 100644
index 2b3d51d97aec..000000000000
--- a/sys-kernel/dracut/dracut-056.ebuild
+++ /dev/null
@@ -1,174 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 linux-info optfeature systemd toolchain-funcs
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dracutdevs/dracut"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
- SRC_URI="https://www.kernel.org/pub/linux/utils/boot/${PN}/${P}.tar.xz"
-fi
-
-DESCRIPTION="Generic initramfs generation tool"
-HOMEPAGE="https://dracut.wiki.kernel.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="selinux test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-arch/cpio
- >=app-shells/bash-4.0:0
- sys-apps/coreutils[xattr(-)]
- >=sys-apps/kmod-23[tools]
- || (
- >=sys-apps/sysvinit-2.87-r3
- sys-apps/openrc[sysv-utils(-),selinux?]
- sys-apps/systemd[sysv-utils]
- )
- >=sys-apps/util-linux-2.21
- virtual/pkgconfig
- virtual/udev
-
- elibc_musl? ( sys-libs/fts-standalone )
- selinux? (
- sec-policy/selinux-dracut
- sys-libs/libselinux
- sys-libs/libsepol
- )
-"
-DEPEND="
- >=sys-apps/kmod-23
- elibc_musl? ( sys-libs/fts-standalone )
-"
-
-BDEPEND="
- app-text/asciidoc
- app-text/docbook-xml-dtd:4.5
- >=app-text/docbook-xsl-stylesheets-1.75.2
- >=dev-libs/libxslt-1.1.26
- virtual/pkgconfig
-"
-
-QA_MULTILIB_PATHS="usr/lib/dracut/.*"
-
-PATCHES=(
- "${FILESDIR}"/gentoo-ldconfig-paths-r1.patch
- "${FILESDIR}"/056-musl.patch
-)
-
-src_configure() {
- local myconf=(
- --prefix="${EPREFIX}/usr"
- --sysconfdir="${EPREFIX}/etc"
- --bashcompletiondir="$(get_bashcompdir)"
- --systemdsystemunitdir="$(systemd_get_systemunitdir)"
- )
-
- tc-export CC PKG_CONFIG
-
- echo ./configure "${myconf[@]}"
- ./configure "${myconf[@]}" || die
-
- if [[ ${PV} != 9999 && ! -f dracut-version.sh ]] ; then
- # Source tarball from github doesn't include this file
- echo "DRACUT_VERSION=${PV}" > dracut-version.sh || die
- fi
-}
-
-src_test() {
- if [[ ${EUID} != 0 ]]; then
- # Tests need root privileges, bug #298014
- ewarn "Skipping tests: Not running as root."
- elif [[ ! -w /dev/kvm ]]; then
- ewarn "Skipping tests: Unable to access /dev/kvm."
- else
- emake -C test check
- fi
-}
-
-src_install() {
- local DOCS=(
- AUTHORS
- NEWS.md
- README.md
- docs/README.cross
- docs/README.generic
- docs/README.kernel
- docs/SECURITY.md
- )
-
- default
-
- docinto html
- dodoc dracut.html
-}
-
-pkg_postinst() {
- if linux-info_get_any_version && linux_config_exists; then
- ewarn ""
- ewarn "If the following test report contains a missing kernel"
- ewarn "configuration option, you should reconfigure and rebuild your"
- ewarn "kernel before booting image generated with this Dracut version."
- ewarn ""
-
- local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS"
-
- # Kernel configuration options descriptions:
- local ERROR_DEVTMPFS='CONFIG_DEVTMPFS: "Maintain a devtmpfs filesystem to mount at /dev" '
- ERROR_DEVTMPFS+='is missing and REQUIRED'
- local ERROR_BLK_DEV_INITRD='CONFIG_BLK_DEV_INITRD: "Initial RAM filesystem and RAM disk '
- ERROR_BLK_DEV_INITRD+='(initramfs/initrd) support" is missing and REQUIRED'
-
- check_extra_config
- echo
- else
- ewarn ""
- ewarn "Your kernel configuration couldn't be checked."
- ewarn "Please check manually if following options are enabled:"
- ewarn ""
- ewarn " CONFIG_BLK_DEV_INITRD"
- ewarn " CONFIG_DEVTMPFS"
- ewarn ""
- fi
-
- optfeature "Networking support" net-misc/networkmanager
- optfeature "Legacy networking support" net-misc/curl "net-misc/dhcp[client]" \
- sys-apps/iproute2 "net-misc/iputils[arping]"
- optfeature \
- "Measure performance of the boot process for later visualisation" \
- app-benchmarks/bootchart2 app-admin/killproc sys-process/acct
- optfeature "Scan for Btrfs on block devices" sys-fs/btrfs-progs
- optfeature "Load kernel modules and drop this privilege for real init" \
- sys-libs/libcap
- optfeature "Support CIFS" net-fs/cifs-utils
- optfeature "Decrypt devices encrypted with cryptsetup/LUKS" \
- "sys-fs/cryptsetup[-static-libs]"
- optfeature "Support for GPG-encrypted keys for crypt module" \
- app-crypt/gnupg
- optfeature \
- "Allows use of dash instead of default bash (on your own risk)" \
- app-shells/dash
- optfeature "Support iSCSI" sys-block/open-iscsi
- optfeature "Support Logical Volume Manager" sys-fs/lvm2
- optfeature "Support MD devices, also known as software RAID devices" \
- sys-fs/mdadm
- optfeature "Support Device Mapper multipathing" sys-fs/multipath-tools
- optfeature "Plymouth boot splash" '>=sys-boot/plymouth-0.8.5-r5'
- optfeature "Support network block devices" sys-block/nbd
- optfeature "Support NFS" net-fs/nfs-utils net-nds/rpcbind
- optfeature \
- "Install ssh and scp along with config files and specified keys" \
- net-misc/openssh
- optfeature "Enable logging with rsyslog" app-admin/rsyslog
- optfeature \
- "Enable rngd service to help generating entropy early during boot" \
- sys-apps/rng-tools
-}
diff --git a/sys-kernel/dracut/files/055-add-blockfuncs.patch b/sys-kernel/dracut/files/055-add-blockfuncs.patch
deleted file mode 100644
index 56724e0c73aa..000000000000
--- a/sys-kernel/dracut/files/055-add-blockfuncs.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From a91dcfeb54b8c6c810020f77124f6eaf6ef5baa9 Mon Sep 17 00:00:00 2001
-From: Lukas Nykryn <lnykryn@redhat.com>
-Date: Thu, 12 Aug 2021 11:46:35 +0200
-Subject: [PATCH] fix(kernel-modules): add blk_mq_alloc_disk and
- blk_cleanup_disk to blockfuncs
-
-Since kernel 5-14 those are used by many drivers for example:
-xen-blkfront, loop, nbd, pd
----
- modules.d/90kernel-modules/module-setup.sh | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/modules.d/90kernel-modules/module-setup.sh b/modules.d/90kernel-modules/module-setup.sh
-index 8b06893ae..69dc18b59 100755
---- a/modules.d/90kernel-modules/module-setup.sh
-+++ b/modules.d/90kernel-modules/module-setup.sh
-@@ -2,7 +2,7 @@
-
- # called by dracut
- installkernel() {
-- local _blockfuncs='ahci_platform_get_resources|ata_scsi_ioctl|scsi_add_host|blk_cleanup_queue|register_mtd_blktrans|scsi_esp_register|register_virtio_device|usb_stor_disconnect|mmc_add_host|sdhci_add_host|scsi_add_host_with_dma'
-+ local _blockfuncs='ahci_platform_get_resources|ata_scsi_ioctl|scsi_add_host|blk_cleanup_queue|register_mtd_blktrans|scsi_esp_register|register_virtio_device|usb_stor_disconnect|mmc_add_host|sdhci_add_host|scsi_add_host_with_dma|blk_mq_alloc_disk|blk_cleanup_disk'
- local -A _hostonly_drvs
-
- find_kernel_modules_external() {
diff --git a/sys-kernel/dracut/files/055-fix-base-do-not-quote-initargs-for-switch_root.patch b/sys-kernel/dracut/files/055-fix-base-do-not-quote-initargs-for-switch_root.patch
deleted file mode 100644
index 5568c22aede6..000000000000
--- a/sys-kernel/dracut/files/055-fix-base-do-not-quote-initargs-for-switch_root.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 285e2ad01035743ff51005a74e486e09fcbb0a0d Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Fri, 23 Jul 2021 14:35:07 -0400
-Subject: [PATCH] fix(base): do not quote $initargs for switch_root
-
-We want word splitting to occur so that the arguments are passed
-separately, and we don't end up passing an empty string if no arguments
-are specified.
-
-Bug: https://bugs.gentoo.org/803548
-Fixes: 2fabaaa62dcfd31e593ca45e1374e55adae29d6b
----
- modules.d/99base/init.sh | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/modules.d/99base/init.sh b/modules.d/99base/init.sh
-index 978adb6f..ab62bb44 100755
---- a/modules.d/99base/init.sh
-+++ b/modules.d/99base/init.sh
-@@ -387,7 +387,8 @@ if [ -f /etc/capsdrop ]; then
- }
- else
- unset RD_DEBUG
-- exec "$SWITCH_ROOT" "$NEWROOT" "$INIT" "$initargs" || {
-+ # shellcheck disable=SC2086
-+ exec "$SWITCH_ROOT" "$NEWROOT" "$INIT" $initargs || {
- warn "Something went very badly wrong in the initramfs. Please "
- warn "file a bug against dracut."
- emergency_shell
---
-2.32.0
-
diff --git a/sys-kernel/dracut/files/055-fix-crypt-remove-quotes-from-cryptsetupopts.patch b/sys-kernel/dracut/files/055-fix-crypt-remove-quotes-from-cryptsetupopts.patch
deleted file mode 100644
index 355cdc461abc..000000000000
--- a/sys-kernel/dracut/files/055-fix-crypt-remove-quotes-from-cryptsetupopts.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From e0abf88a15d23fbf793cf872397016ad86aeaaa8 Mon Sep 17 00:00:00 2001
-From: lapseofreason <lapseofreason0@gmail.com>
-Date: Tue, 8 Jun 2021 16:01:58 +0200
-Subject: [PATCH] fix(crypt): remove quotes from cryptsetupopts
-
-Fixes #1528.
----
- modules.d/90crypt/cryptroot-ask.sh | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/modules.d/90crypt/cryptroot-ask.sh b/modules.d/90crypt/cryptroot-ask.sh
-index 37a4deea..b1f8df81 100755
---- a/modules.d/90crypt/cryptroot-ask.sh
-+++ b/modules.d/90crypt/cryptroot-ask.sh
-@@ -138,8 +138,9 @@ unset allowdiscards
- ask_passphrase=1
-
- if [ -n "$luksfile" -a "$luksfile" != "none" -a -e "$luksfile" ]; then
-+ # shellcheck disable=SC2086
- if readkey "$luksfile" / "$device" \
-- | cryptsetup -d - "$cryptsetupopts" luksOpen "$device" "$luksname"; then
-+ | cryptsetup -d - $cryptsetupopts luksOpen "$device" "$luksname"; then
- ask_passphrase=0
- fi
- elif [ "$is_keysource" -ne 0 ]; then
-@@ -164,8 +165,9 @@ else
- unset tmp
-
- info "Using '$keypath' on '$keydev'"
-+ # shellcheck disable=SC2086
- readkey "$keypath" "$keydev" "$device" \
-- | cryptsetup -d - "$cryptsetupopts" luksOpen "$device" "$luksname" \
-+ | cryptsetup -d - $cryptsetupopts luksOpen "$device" "$luksname" \
- && ask_passphrase=0
- unset keypath keydev
- break
---
-2.32.0
-
diff --git a/sys-kernel/dracut/files/055-fix-usrmount-do-not-empty-_dev-variable.patch b/sys-kernel/dracut/files/055-fix-usrmount-do-not-empty-_dev-variable.patch
deleted file mode 100644
index e46f8bb25db9..000000000000
--- a/sys-kernel/dracut/files/055-fix-usrmount-do-not-empty-_dev-variable.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 4afdcba212793f136aea012b30dd7bdb5b641a5a Mon Sep 17 00:00:00 2001
-From: Alexander Tsoy <alexander@tsoy.me>
-Date: Mon, 16 Aug 2021 18:54:34 +0300
-Subject: [PATCH] fix(usrmount): do not empty _dev variable
-
-Currently $_dev is always overridden with the value returned by
-label_uuid_to_dev(). This results in an empty value if $_dev is a
-device path. Fix this by calling label_uuid_to_dev() conditionally.
-
-Bug: https://bugs.gentoo.org/807971
-Fixes: d3532978de04c78f53664dad7b37705a49a7ee54
----
- modules.d/98usrmount/mount-usr.sh | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/modules.d/98usrmount/mount-usr.sh b/modules.d/98usrmount/mount-usr.sh
-index 23ed06aa..c8e1893b 100755
---- a/modules.d/98usrmount/mount-usr.sh
-+++ b/modules.d/98usrmount/mount-usr.sh
-@@ -55,7 +55,12 @@ mount_usr() {
- while read -r _dev _mp _fs _opts _freq _passno || [ -n "$_dev" ]; do
- [ "${_dev%%#*}" != "$_dev" ] && continue
- if [ "$_mp" = "/usr" ]; then
-- _dev="$(label_uuid_to_dev "$_dev")"
-+ case "$_dev" in
-+ LABEL=* | UUID=* | PARTUUID=* | PARTLABEL=*)
-+ _dev="$(label_uuid_to_dev "$_dev")"
-+ ;;
-+ *) ;;
-+ esac
-
- if strstr "$_opts" "subvol=" \
- && [ "${root#block:}" -ef "$_dev" ] \
---
-2.31.1
-
diff --git a/sys-kernel/dracut/files/055-tpm2-tss-typo.patch b/sys-kernel/dracut/files/055-tpm2-tss-typo.patch
deleted file mode 100644
index a04496a29ca8..000000000000
--- a/sys-kernel/dracut/files/055-tpm2-tss-typo.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 8b17105bed69ed90582a13d97d95ee19e6581365 Mon Sep 17 00:00:00 2001
-From: Matthias Berndt <matthias_berndt@gmx.de>
-Date: Tue, 1 Jun 2021 19:32:48 +0200
-Subject: [PATCH] fix(tpm2-tss): typo in depends()
-
-There is no systemd-udev module, only systemd-udevd
----
- modules.d/91tpm2-tss/module-setup.sh | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/modules.d/91tpm2-tss/module-setup.sh b/modules.d/91tpm2-tss/module-setup.sh
-index 28af22a31..361131d66 100755
---- a/modules.d/91tpm2-tss/module-setup.sh
-+++ b/modules.d/91tpm2-tss/module-setup.sh
-@@ -17,7 +17,7 @@ check() {
- depends() {
-
- # This module has external dependency on other module(s).
-- echo systemd-sysusers systemd-udev
-+ echo systemd-sysusers systemd-udevd
- # Return 0 to include the dependent module(s) in the initramfs.
- return 0
-
diff --git a/sys-kernel/dracut/files/056-fix-lvm-add-missing-grep-requirement.patch b/sys-kernel/dracut/files/056-fix-lvm-add-missing-grep-requirement.patch
deleted file mode 100644
index ca24180fd689..000000000000
--- a/sys-kernel/dracut/files/056-fix-lvm-add-missing-grep-requirement.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 79f9d9e1c29a9c8fc046ab20765e5bde2aaa3428 Mon Sep 17 00:00:00 2001
-From: Antonio Alvarez Feijoo <antonio.feijoo@suse.com>
-Date: Mon, 11 Apr 2022 08:33:17 +0200
-Subject: [PATCH] fix(lvm): add missing grep requirement
-
-Since commit https://github.com/dracutdevs/dracut/commit/7ffc5e38
-lvm_scan.sh needs grep.
----
- modules.d/90lvm/module-setup.sh | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/modules.d/90lvm/module-setup.sh b/modules.d/90lvm/module-setup.sh
-index 25be0133..aa8c6db8 100755
---- a/modules.d/90lvm/module-setup.sh
-+++ b/modules.d/90lvm/module-setup.sh
-@@ -3,7 +3,7 @@
- # called by dracut
- check() {
- # No point trying to support lvm if the binaries are missing
-- require_binaries lvm || return 1
-+ require_binaries lvm grep || return 1
-
- [[ $hostonly ]] || [[ $mount_needs ]] && {
- for fs in "${host_fs_types[@]}"; do
-@@ -48,7 +48,7 @@ installkernel() {
-
- # called by dracut
- install() {
-- inst lvm
-+ inst_multiple lvm grep
-
- if [[ $hostonly_cmdline == "yes" ]]; then
- local _lvmconf
---
-2.35.1
-
diff --git a/sys-kernel/dracut/files/056-musl.patch b/sys-kernel/dracut/files/056-musl.patch
deleted file mode 100644
index ded188889755..000000000000
--- a/sys-kernel/dracut/files/056-musl.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From ce55a85ed5d902c19d75895508856f96ec2ceb1a Mon Sep 17 00:00:00 2001
-From: Laszlo Gombos <laszlo.gombos@gmail.com>
-Date: Sun, 20 Feb 2022 22:23:49 -0500
-Subject: [PATCH] fix(install): restore musl support
-
-__GLIBC_PREREQ is only defined in glibc.
----
- src/install/util.c | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/src/install/util.c b/src/install/util.c
-index 5721de89e..0af387c27 100644
---- a/src/install/util.c
-+++ b/src/install/util.c
-@@ -24,17 +24,15 @@
- #include <errno.h>
- #include <fcntl.h>
- #include <sys/types.h>
-+#include <sys/syscall.h>
-
- #include "util.h"
-
--#if __GLIBC_PREREQ(2, 30) == 0
--#include <sys/syscall.h>
- #ifndef SYS_gettid
- #error "SYS_gettid unavailable on this system"
- #endif
-
- #define gettid() ((pid_t) syscall(SYS_gettid))
--#endif /*__GLIBC_PREREQ */
-
- size_t page_size(void)
- {