summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-07-14 13:30:38 -0400
committerMike Pagano <mpagano@gentoo.org>2021-07-14 13:30:38 -0400
commit743ab401112ef2749012ac5a4e90f82cd2bfea9d (patch)
treee30ce093389a7f3d898ea09f3bdb7343dfb8f2ed /sys-kernel/gentoo-sources/gentoo-sources-5.4.132.ebuild
parentdev-ml/opam-file-format: bump to 2.1.3 (diff)
downloadgentoo-743ab401112ef2749012ac5a4e90f82cd2bfea9d.tar.gz
gentoo-743ab401112ef2749012ac5a4e90f82cd2bfea9d.tar.bz2
gentoo-743ab401112ef2749012ac5a4e90f82cd2bfea9d.zip
sys-kernel/gentoo-sources: Linux updates and genpatches
Linux 5.13.2 and BMQ Schedular patch Linux 5.12.17 Linux 5.10.50 and revert of patch: 2400_revert-ibmvnic-remove-duplicate-napi_schedule-call-i.patch Linux 5.4.132 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-5.4.132.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.4.132.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.4.132.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.4.132.ebuild
new file mode 100644
index 000000000000..71daa7dab960
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.4.132.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="136"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}