summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrits Letteboer <dagraver@gmail.com>2023-10-27 17:07:03 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-11-16 11:03:39 +0200
commit02e8840a18b0b7f2823edb070795c5418b91dfaf (patch)
tree1a0a0db29aa7968d097c375ffdff6be5d9cb3d52 /sys-kernel/pf-sources
parentmail-client/thunderbird: add 115.4.3 (diff)
downloadgentoo-02e8840a18b0b7f2823edb070795c5418b91dfaf.tar.gz
gentoo-02e8840a18b0b7f2823edb070795c5418b91dfaf.tar.bz2
gentoo-02e8840a18b0b7f2823edb070795c5418b91dfaf.zip
sys-kernel/pf-sources: add 6.5-pf6
Signed-off-by: Frits Letteboer <dagraver@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-6.5_p6.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index d00b1a09082f..cedee9abaf9f 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -1,3 +1,4 @@
DIST genpatches-6.5-1.base.tar.xz 4888 BLAKE2B adcbb4c9f48e94781dfb3f38b32f4d60b555857ceb35f48ea19c1bafd9408d65d58a603abe994390ee970ce6fbd6ac9a75e56f2b924a0c9a5dad6cd11620c9b1 SHA512 7317fea243022a75ad3d9856030bcdb273ff55c7b865f71d29aa2799510cc3310d05cc0e63061c8ed11df8d9e820c1b4cbab310a627fbc7a2e15d8ca00b61fe5
DIST genpatches-6.5-1.extras.tar.xz 3700 BLAKE2B b9fd452eb544031092219faddff94e96c48e7b39815fd48922b959a8d44033e443368f9825c5ffedc9f75fb851a74a6c252b9c7b9bdaaadb78727b804a7e9c5f SHA512 813a15a65ce8033d34b9eb42749fd7b2f2a604288b4c3a56aef295c994322c5cc95dd14fd35ac8335d3d036bdb708cadfc8bf2a4b35c406f420589af476bcf98
DIST linux-6.5-pf5.tar.gz 228002908 BLAKE2B 9a2aae312b54ff78546bc8c5930510bad72a6c856602adc404b8e4c1e59bba22445b263c8480377e17a5f2698c7efc21c75bf1ad06ebdee31a64fe8fdaa46ed9 SHA512 77cfd8f869b4b5da1f6109f16125605875246233880a71b27545a97bd76d42f78c07c419b7526c5313b591a055430fa8b4fd271192a872b944092520222f4a2f
+DIST linux-6.5-pf6.tar.gz 227889902 BLAKE2B d45e370b566cc903bf9cc0880e4f50a68ea675073e81d3784c9e173c21939b68a1f5ab2d7e6740da303c98be8f469c10859f0814cf6e32a6b284cab0d96e21b2 SHA512 b9bbc97b865c5086afbcf3ba8532ed2723dbdb069323eb352f8b33dc5c69b75aae88ab7bfa5090c9f9f624eea4ee1287c301132d87e12b56a4ac6ece317ad668
diff --git a/sys-kernel/pf-sources/pf-sources-6.5_p6.ebuild b/sys-kernel/pf-sources/pf-sources-6.5_p6.ebuild
new file mode 100644
index 000000000000..2ee0009ae2d4
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-6.5_p6.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Define what default functions to run.
+ETYPE="sources"
+
+# Use genpatches but don't include the 'experimental' use flag.
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Genpatches version to use. -pf patch set already includes vanilla linux updates. Regularly "1"
+# is the wanted value here, but the genpatches patch set can be bumped if it includes some
+# important fixes. src_prepare() will handle deleting the updated vanilla linux patches.
+# See https://archives.gentoo.org/gentoo-kernel/ (or subscribe to the list) to see all patches.
+K_GENPATCHES_VER="1"
+
+# -pf patch set already sets EXTRAVERSION to kernel Makefile.
+K_NOSETEXTRAVERSION="1"
+
+# pf-sources is not officially supported/covered by the Gentoo security team.
+K_SECURITY_UNSUPPORTED="1"
+
+# Define which parts to use from genpatches - experimental is already included in the -pf patch
+# set.
+K_WANT_GENPATCHES="base extras"
+
+# Major kernel version, e.g. 5.14.
+SHPV="${PV/_p*/}"
+
+# Replace "_p" with "-pf", since using "-pf" is not allowed for an ebuild name by PMS.
+PFPV="${PV/_p/-pf}"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://pfkernel.natalenko.name/
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="https://codeberg.org/pf-kernel/linux/archive/v${PFPV}.tar.gz -> linux-${PFPV}.tar.gz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PFPV}"
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_unpack() {
+ # Since the Codeberg-hosted pf-sources include full kernel sources, we need to manually override
+ # the src_unpack phase because kernel-2_src_unpack() does a lot of unwanted magic here.
+ unpack ${A}
+
+ mv linux linux-${PFPV} || die "Failed to move source directory"
+}
+
+src_prepare() {
+ # When genpatches basic version is bumped, it also includes vanilla linux updates. Those are
+ # already in the -pf patch set, so need to remove the vanilla linux patches to avoid conflicts.
+ if [[ ${K_GENPATCHES_VER} -ne 1 ]]; then
+ find "${WORKDIR}"/ -type f -name '10*linux*patch' -delete ||
+ die "Failed to delete vanilla linux patches in src_prepare."
+ fi
+
+ # kernel-2_src_prepare doesn't apply PATCHES(). Chosen genpatches are also applied here.
+ eapply "${WORKDIR}"/*.patch
+ default
+}
+
+pkg_postinst() {
+ # Fixes "wrongly" detected directory name, bgo#862534.
+ local KV_FULL="${PFPV}"
+ kernel-2_pkg_postinst
+
+ optfeature "userspace KSM helper" sys-process/uksmd
+}
+
+pkg_postrm() {
+ # Same here, bgo#862534.
+ local KV_FULL="${PFPV}"
+ kernel-2_pkg_postrm
+}