summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2015-11-28 14:00:58 +0100
committerTupone Alfredo <tupone@gentoo.org>2015-11-28 14:00:58 +0100
commit4ef4ab39f9df14ccce421396ab7b5ec65179b21e (patch)
tree8d889fd2a3af7feece957effd7e958b88ebeb0ca /sys-kernel/raspberrypi-sources
parentdev-lang/php: bump php7 rc (diff)
downloadgentoo-4ef4ab39f9df14ccce421396ab7b5ec65179b21e.tar.gz
gentoo-4ef4ab39f9df14ccce421396ab7b5ec65179b21e.tar.bz2
gentoo-4ef4ab39f9df14ccce421396ab7b5ec65179b21e.zip
sys-kernel/raspberrypi-sources: Bump to 4.1
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-kernel/raspberrypi-sources')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.1.9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.1.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.1.9999.ebuild
new file mode 100644
index 000000000000..9e7224829a8d
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.1.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}