summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-10-24 04:20:31 +0800
committerJason Zaman <perfinion@gentoo.org>2015-10-24 04:26:53 +0800
commitd0753f81463ceb3e99bd6baf12eb2f3c6399a5b9 (patch)
treebd38745e4f3810665e3e728cb20222961cb585eb /sys-kernel/spl
parentsys-cluster/neutron: remove this commit (diff)
downloadgentoo-d0753f81463ceb3e99bd6baf12eb2f3c6399a5b9.tar.gz
gentoo-d0753f81463ceb3e99bd6baf12eb2f3c6399a5b9.tar.bz2
gentoo-d0753f81463ceb3e99bd6baf12eb2f3c6399a5b9.zip
sys-kernel/spl: update live ebuild
- update to EAPI 5 - update to git-r3 eclass - change src_uri to release tarballs
Diffstat (limited to 'sys-kernel/spl')
-rw-r--r--sys-kernel/spl/spl-9999.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/sys-kernel/spl/spl-9999.ebuild b/sys-kernel/spl/spl-9999.ebuild
index 43c6711ec668..02bef881fc0a 100644
--- a/sys-kernel/spl/spl-9999.ebuild
+++ b/sys-kernel/spl/spl-9999.ebuild
@@ -2,21 +2,19 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
-AUTOTOOLS_AUTORECONF="1"
-
-inherit flag-o-matic linux-info linux-mod autotools-utils
+EAPI="5"
if [[ ${PV} == "9999" ]] ; then
- inherit git-2
+ AUTOTOOLS_AUTORECONF="1"
EGIT_REPO_URI="https://github.com/zfsonlinux/${PN}.git"
+ inherit git-r3
else
- inherit eutils versionator
- SRC_URI="https://github.com/zfsonlinux/${PN}/archive/${P}.tar.gz"
- S="${WORKDIR}/${PN}-${P}"
+ SRC_URI="https://github.com/zfsonlinux/zfs/releases/download/zfs-${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
fi
+inherit flag-o-matic linux-info linux-mod autotools-utils
+
DESCRIPTION="The Solaris Porting Layer is a Linux kernel module which provides many of the Solaris kernel APIs"
HOMEPAGE="http://zfsonlinux.org/"
@@ -35,6 +33,7 @@ RDEPEND="${COMMON_DEPEND}
AT_M4DIR="config"
AUTOTOOLS_IN_SOURCE_BUILD="1"
+DOCS=( AUTHORS DISCLAIMER README.markdown )
pkg_setup() {
linux-info_pkg_setup
@@ -96,7 +95,6 @@ src_configure() {
src_install() {
autotools-utils_src_install INSTALL_MOD_PATH="${INSTALL_MOD_PATH:-$EROOT}"
- dodoc AUTHORS DISCLAIMER README.markdown
}
pkg_postinst() {