summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-12-08 22:16:34 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-09 01:26:03 +0800
commita846ff60cdb5e60e9eb81068470179a1340e1661 (patch)
tree0696b525bd4d5ce2e84d6b2eb093035c7767ac49 /sys-libs/libsepol/libsepol-3.0.ebuild
parentsys-apps/restorecond: update live ebuild (diff)
downloadgentoo-a846ff60cdb5e60e9eb81068470179a1340e1661.tar.gz
gentoo-a846ff60cdb5e60e9eb81068470179a1340e1661.tar.bz2
gentoo-a846ff60cdb5e60e9eb81068470179a1340e1661.zip
sys-libs/libsepol: bump to 3.0
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-libs/libsepol/libsepol-3.0.ebuild')
-rw-r--r--sys-libs/libsepol/libsepol-3.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-libs/libsepol/libsepol-3.0.ebuild b/sys-libs/libsepol/libsepol-3.0.ebuild
new file mode 100644
index 000000000000..cd78384ffb9b
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit multilib toolchain-funcs multilib-minimal
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20191204"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export CC AR RANLIB
+ emake \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ install
+}