summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-03-26 20:00:09 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-03-26 20:06:34 +0100
commit91bd0dbf708a0aefe25587938c75c8619c619586 (patch)
tree2b3ae022ec0bc3f54805bac11801e87383d56e60 /sys-libs/tevent/tevent-0.10.0.ebuild
parentsys-libs/ldb: Removed old (diff)
downloadgentoo-91bd0dbf708a0aefe25587938c75c8619c619586.tar.gz
gentoo-91bd0dbf708a0aefe25587938c75c8619c619586.tar.bz2
gentoo-91bd0dbf708a0aefe25587938c75c8619c619586.zip
sys-libs/tevent: Removed old
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/tevent/tevent-0.10.0.ebuild')
-rw-r--r--sys-libs/tevent/tevent-0.10.0.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/sys-libs/tevent/tevent-0.10.0.ebuild b/sys-libs/tevent/tevent-0.10.0.ebuild
deleted file mode 100644
index 08d3a959b252..000000000000
--- a/sys-libs/tevent/tevent-0.10.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit waf-utils multilib-minimal python-single-r1
-
-DESCRIPTION="Samba tevent library"
-HOMEPAGE="https://tevent.samba.org/"
-SRC_URI="https://www.samba.org/ftp/tevent/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-linux"
-IUSE="elibc_glibc python"
-
-RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
- >=sys-libs/talloc-2.2.0[${MULTILIB_USEDEP}]
- python? ( ${PYTHON_DEPS} )"
-
-DEPEND="${RDEPEND}
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- elibc_glibc? (
- net-libs/libtirpc[${MULTILIB_USEDEP}]
- || (
- net-libs/rpcsvc-proto
- <sys-libs/glibc-2.26[rpc(+)]
- )
- )
- ${PYTHON_DEPS}
-"
-# build system does not work with python3
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-RESTRICT="test"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- waf-utils_src_configure \
- --bundled-libraries=NONE \
- --builtin-libraries=NONE \
- $(multilib_native_usex python '' '--disable-python')
-}
-
-multilib_src_compile() {
- # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
- unset MAKEOPTS
- waf-utils_src_compile
-}
-
-multilib_src_install() {
- waf-utils_src_install
-
- multilib_is_native_abi && use python && python_domodule tevent.py
-}
-
-multilib_src_install_all() {
- insinto /usr/include
- doins tevent_internal.h
-}