summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 09:34:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-01 14:15:55 +0100
commit4ae3692f2acf6307068366779505aecec3f2254a (patch)
tree0de64b0479e0f711cd2a41647cc2f0f9270d83e7 /sys-libs
parentsys-libs/libcxx: Switch live to monorepo (diff)
downloadgentoo-4ae3692f2acf6307068366779505aecec3f2254a.tar.gz
gentoo-4ae3692f2acf6307068366779505aecec3f2254a.tar.bz2
gentoo-4ae3692f2acf6307068366779505aecec3f2254a.zip
sys-libs/libcxxabi: Switch live to monorepo
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxxabi/libcxxabi-10.0.0.9999.ebuild17
-rw-r--r--sys-libs/libcxxabi/libcxxabi-9.0.1.9999.ebuild19
2 files changed, 13 insertions, 23 deletions
diff --git a/sys-libs/libcxxabi/libcxxabi-10.0.0.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-10.0.0.9999.ebuild
index edc18f6fea90..8a1fd469ee76 100644
--- a/sys-libs/libcxxabi/libcxxabi-10.0.0.9999.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-10.0.0.9999.ebuild
@@ -13,8 +13,8 @@ inherit cmake-multilib git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="Low level support for a standard C++ library"
HOMEPAGE="https://libcxxabi.llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/libcxxabi.git
- https://github.com/llvm-mirror/libcxxabi.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/libcxxabi
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
@@ -49,14 +49,9 @@ pkg_setup() {
}
src_unpack() {
- # we need the headers
- git-r3_fetch "https://git.llvm.org/git/libcxx.git
- https://github.com/llvm-mirror/libcxx.git"
git-r3_fetch
-
- git-r3_checkout https://llvm.org/git/libcxx.git \
- "${WORKDIR}"/libcxx ''
- git-r3_checkout
+ # we always need libcxx for the headers
+ git-r3_checkout '' '' '' libcxx{,abi}
}
multilib_src_configure() {
@@ -68,7 +63,7 @@ multilib_src_configure() {
-DLIBCXXABI_USE_LLVM_UNWINDER=$(usex libunwind)
-DLIBCXXABI_INCLUDE_TESTS=$(usex test)
- -DLIBCXXABI_LIBCXX_INCLUDES="${WORKDIR}"/libcxx/include
+ -DLIBCXXABI_LIBCXX_INCLUDES="${WORKDIR}/${P}"/libcxx/include
# upstream is omitting standard search path for this
# probably because gcc & clang are bundling their own unwind.h
-DLIBCXXABI_LIBUNWIND_INCLUDES="${EPREFIX}"/usr/include
@@ -89,7 +84,7 @@ multilib_src_configure() {
build_libcxx() {
local -x LDFLAGS="${LDFLAGS} -L${BUILD_DIR}/$(get_libdir)"
- local CMAKE_USE_DIR=${WORKDIR}/libcxx
+ local CMAKE_USE_DIR=${WORKDIR}/${P}/libcxx
local BUILD_DIR=${BUILD_DIR}/libcxx
local mycmakeargs=(
-DLIBCXX_LIBDIR_SUFFIX=
diff --git a/sys-libs/libcxxabi/libcxxabi-9.0.1.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-9.0.1.9999.ebuild
index 70fcb998c05d..591bf45eca84 100644
--- a/sys-libs/libcxxabi/libcxxabi-9.0.1.9999.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-9.0.1.9999.ebuild
@@ -13,9 +13,9 @@ inherit cmake-multilib git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="Low level support for a standard C++ library"
HOMEPAGE="https://libcxxabi.llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/libcxxabi.git
- https://github.com/llvm-mirror/libcxxabi.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/libcxxabi
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
@@ -50,14 +50,9 @@ pkg_setup() {
}
src_unpack() {
- # we need the headers
- git-r3_fetch "https://git.llvm.org/git/libcxx.git
- https://github.com/llvm-mirror/libcxx.git"
git-r3_fetch
-
- git-r3_checkout https://llvm.org/git/libcxx.git \
- "${WORKDIR}"/libcxx ''
- git-r3_checkout
+ # we always need libcxx for the headers
+ git-r3_checkout '' '' '' libcxx{,abi}
}
multilib_src_configure() {
@@ -69,7 +64,7 @@ multilib_src_configure() {
-DLIBCXXABI_USE_LLVM_UNWINDER=$(usex libunwind)
-DLIBCXXABI_INCLUDE_TESTS=$(usex test)
- -DLIBCXXABI_LIBCXX_INCLUDES="${WORKDIR}"/libcxx/include
+ -DLIBCXXABI_LIBCXX_INCLUDES="${WORKDIR}/${P}"/libcxx/include
# upstream is omitting standard search path for this
# probably because gcc & clang are bundling their own unwind.h
-DLIBCXXABI_LIBUNWIND_INCLUDES="${EPREFIX}"/usr/include
@@ -90,7 +85,7 @@ multilib_src_configure() {
build_libcxx() {
local -x LDFLAGS="${LDFLAGS} -L${BUILD_DIR}/$(get_libdir)"
- local CMAKE_USE_DIR=${WORKDIR}/libcxx
+ local CMAKE_USE_DIR=${WORKDIR}/${P}/libcxx
local BUILD_DIR=${BUILD_DIR}/libcxx
local mycmakeargs=(
-DLIBCXX_LIBDIR_SUFFIX=