summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-27 10:36:57 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-27 10:36:57 +0200
commita5a7a8d7ad7d67509fda6621bce6f4bc84f69822 (patch)
treec22ea373b3c530afe771156d4594b29a3b0b8a14 /sys-libs
parentRevert "x11-misc/lightdm: use upstream lightdm-greeter pam config" (diff)
downloadgentoo-a5a7a8d7ad7d67509fda6621bce6f4bc84f69822.tar.gz
gentoo-a5a7a8d7ad7d67509fda6621bce6f4bc84f69822.tar.bz2
gentoo-a5a7a8d7ad7d67509fda6621bce6f4bc84f69822.zip
sys-libs/libblockdev: Bump to version 2.20
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libblockdev/Manifest1
-rw-r--r--sys-libs/libblockdev/libblockdev-2.20.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-libs/libblockdev/Manifest b/sys-libs/libblockdev/Manifest
index 8bbaeeee6055..ae0704dab1e5 100644
--- a/sys-libs/libblockdev/Manifest
+++ b/sys-libs/libblockdev/Manifest
@@ -1,3 +1,4 @@
DIST libblockdev-2.14-1.tar.gz 274241 BLAKE2B 64c4c2a298ed95ed24a79716ccef5930f4276faaca02acf883c386b85a662d3fa1dc6f30e00d99bd835832e3c65acb89b445eff6fb35f9090dc949efde737d1a SHA512 fb80e840ed2f247912da93a6cc0cb1846be73dcc16b917f5231f5d7a87eaa7b43d07d5b2110038dd783fefa7ef7df0893785a60079ed02567f1e08bfcbd82343
DIST libblockdev-2.18-1.tar.gz 310870 BLAKE2B afeb904938c9700917e3bf55665bfa5612677b963e4273378046edae15f94b90f2e85c31f12b196317fe26c4befe9ae514822d987fdc8003bc1b0cc49cd61dac SHA512 c7837b0abb7747baf8dc2a21a0a75bc5fb80693a1685ddb310bf7d606d44ea65fa4c934cff6c09c5069806dea3ee056eb53c64122ec43b5c0485cdf92fda58d5
DIST libblockdev-2.19-1.tar.gz 334391 BLAKE2B 1db31a5051822d4e6f4cc024f6eeee0c936430527614fc41b80ef36f08a2d77f24bd7a66b81d094c8f468d31561dd802754e9079565b3e177296f558a8b18fcb SHA512 945671600036c8d923a2af9a2044535c78d6e887c3a02b0f7ce782cf9deff7f962b7a96fd092cd408aa48717665afa1db7b8d3f7b33e572fd2beb13df98f5c7d
+DIST libblockdev-2.20-1.tar.gz 338039 BLAKE2B 77923e52b10e7853ae9433bf811d3a08f1c18da81d4f148b220d7e4101535f245612f0c82c96c6c3bc3e4c0631ada153c59c4587a86efdc5669a0b9f69e764be SHA512 4cb6b18d5de63461f35e0b6f6896599aa41da2c995839c2e88661dacdf07522842b612820fb1d83edbde72092cc62295d5411e8607f52c611db7f02aa16c9ab3
diff --git a/sys-libs/libblockdev/libblockdev-2.20.ebuild b/sys-libs/libblockdev/libblockdev-2.20.ebuild
new file mode 100644
index 000000000000..d1eb0822af1c
--- /dev/null
+++ b/sys-libs/libblockdev/libblockdev-2.20.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+inherit autotools python-single-r1
+
+MY_PV="${PV}-1"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A library for manipulating block devices"
+HOMEPAGE="https://github.com/storaged-project/libblockdev"
+SRC_URI="https://github.com/storaged-project/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bcache +cryptsetup dmraid doc escrow lvm kbd test vdo"
+
+RDEPEND="
+ >=dev-libs/glib-2.42.2
+ dev-libs/libbytesize
+ >=sys-apps/kmod-19
+ >=sys-apps/util-linux-2.27
+ >=sys-block/parted-3.1
+ cryptsetup? (
+ escrow? (
+ >=dev-libs/nss-3.18.0
+ dev-libs/volume_key
+ )
+ >=sys-fs/cryptsetup-1.6.7:=
+ )
+ dmraid? (
+ sys-fs/dmraid
+ sys-fs/lvm2
+ )
+ lvm? (
+ sys-fs/lvm2
+ virtual/udev
+ )
+ vdo? ( dev-libs/libyaml )
+ ${PYTHON_DEPS}
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/gobject-introspection-1.3.0
+ doc? ( dev-util/gtk-doc )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ escrow? ( cryptsetup )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-btrfs
+ --with-fs
+ --with-part
+ --without-mpath
+ --without-nvdimm
+ $(use_enable test tests)
+ $(use_with bcache)
+ $(use_with cryptsetup crypto)
+ $(use_with dmraid)
+ $(use_with doc gtk-doc)
+ $(use_with escrow)
+ $(use_with lvm lvm)
+ $(use_with lvm lvm-dbus)
+ $(use_with kbd)
+ $(use_with vdo)
+ )
+ if python_is_python3 ; then
+ myeconfargs+=(
+ --without-python2
+ --with-python3
+ )
+ else
+ myeconfargs+=(
+ --with-python2
+ --without-python3
+ )
+ fi
+ econf "${myeconfargs[@]}"
+}