summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-09-06 20:29:49 +0200
committerPacho Ramos <pacho@gentoo.org>2024-09-06 20:29:49 +0200
commit0961b0100c49aa6abb585932439eb0597bd837b7 (patch)
tree743bca6d8b9e1d1b26d88d1adbf5c47e68c5622c /sys-power
parentsys-power/power-profiles-daemon: add 0.22 (diff)
downloadgentoo-0961b0100c49aa6abb585932439eb0597bd837b7.tar.gz
gentoo-0961b0100c49aa6abb585932439eb0597bd837b7.tar.bz2
gentoo-0961b0100c49aa6abb585932439eb0597bd837b7.zip
sys-power/power-profiles-daemon: drop 0.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/power-profiles-daemon/Manifest1
-rw-r--r--sys-power/power-profiles-daemon/power-profiles-daemon-0.20.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/sys-power/power-profiles-daemon/Manifest b/sys-power/power-profiles-daemon/Manifest
index 8f17e457df10..0574516d26ff 100644
--- a/sys-power/power-profiles-daemon/Manifest
+++ b/sys-power/power-profiles-daemon/Manifest
@@ -1,3 +1,2 @@
-DIST power-profiles-daemon-0.20.tar.bz2 58388 BLAKE2B f25bc2618441f53624567c4f40d9960b28bf46fb2098eb0e2098207149df3d4923a13c40d781885e37708bf896b537ccb969ec7a928669a3776722e5e58801cf SHA512 2236aac94dafbf6fd951f3bd44953f1a14bc7c5e55349307374d836e20377e1768dcf1250fa8dcf9f01d4eddea8ab64082881189b4e958fbfcd5e2e90d3e823a
DIST power-profiles-daemon-0.21.tar.bz2 63984 BLAKE2B 206c954272fb93b17a09e4108c74462d2524ef9160880ce59709504314fd38f413c7eb65ab4f0a085f6458b04f85b4833e0df3786f0aff08e7bdc0a3a65d8d2a SHA512 8038ff7c164bbcbeebc50c911f3129e79d4f8d63278bc674e10bf2920af0bc9b0b139d5a2e056889b0b7ec86df19cc7be3e8c84e70e777544e117ee7a036b375
DIST power-profiles-daemon-0.22.tar.bz2 66394 BLAKE2B 7c204aa29ebda4f9034729b5ea09e1cd516a788c0fc58cf57f49791103f85506bc34bf8c2db9a4f1e42fa280ba4d6ce1c095df3a90deb90db795d7c02b4d6606 SHA512 7fcb960f956ad95cfa7f31ac8d8b3070ff72822106017177cdab873c2e8e6017d7357b09fea2a14450990acc844f7db30d5cdcce33d59661c775da54ad095af9
diff --git a/sys-power/power-profiles-daemon/power-profiles-daemon-0.20.ebuild b/sys-power/power-profiles-daemon/power-profiles-daemon-0.20.ebuild
deleted file mode 100644
index 0df1a8b0c644..000000000000
--- a/sys-power/power-profiles-daemon/power-profiles-daemon-0.20.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit meson python-single-r1 systemd
-
-DESCRIPTION="Makes power profiles handling available over D-Bus"
-HOMEPAGE="https://gitlab.freedesktop.org/upower/power-profiles-daemon/"
-SRC_URI="https://gitlab.freedesktop.org/upower/${PN}/-/archive/${PV}/${P}.tar.bz2"
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-
-IUSE="gtk-doc selinux test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
- dev-libs/glib:2
- >=dev-libs/libgudev-234
- >=sys-auth/polkit-0.99
- sys-power/upower
- selinux? ( sec-policy/selinux-powerprofiles )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-util/glib-utils
- gtk-doc? (
- dev-util/gi-docgen
- dev-util/gtk-doc
- )
- test? (
- dev-util/umockdev
- $(python_gen_cond_dep '
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-dbusmock[${PYTHON_USEDEP}]
- ')
- )
-"
-
-python_check_deps() {
- if use test; then
- python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]" &&
- python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
- else
- python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
- fi
-}
-
-src_configure() {
- local emesonargs=(
- -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
- $(meson_use gtk-doc gtk_doc)
- $(meson_use test tests)
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- python_fix_shebang "${D}"/usr/bin/powerprofilesctl
- newinitd "${FILESDIR}/power-profiles-daemon.initd" power-profiles-daemon
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "You need to enable the service:"
- if systemd_is_booted; then
- elog "# systemctl enable ${PN}"
- else
- elog "# rc-update add ${PN} default"
- fi
- fi
-}