summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Fabrizio Orsi <torsi@fi.uba.ar>2023-09-06 10:17:00 -0300
committerMike Gilbert <floppym@gentoo.org>2023-09-06 13:09:34 -0400
commit489f2e822cae71afe2a8ccd0955b288570a57d15 (patch)
tree970d10e387db9c73468271d9b22bcef64aed0b4d /sys-process/cronbase
parentsys-process/cronbase: Added elog message about the cron group (diff)
downloadgentoo-489f2e822cae71afe2a8ccd0955b288570a57d15.tar.gz
gentoo-489f2e822cae71afe2a8ccd0955b288570a57d15.tar.bz2
gentoo-489f2e822cae71afe2a8ccd0955b288570a57d15.zip
sys-process/cronbase: changed from elog to readme.gentoo_print_elog
Signed-off-by: Tomas Fabrizio Orsi <torsi@fi.uba.ar> Closes: https://github.com/gentoo/gentoo/pull/32642 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-process/cronbase')
-rw-r--r--sys-process/cronbase/cronbase-0.3.7-r10.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/sys-process/cronbase/cronbase-0.3.7-r10.ebuild b/sys-process/cronbase/cronbase-0.3.7-r10.ebuild
index 5d70784a26c8..416f6483ad62 100644
--- a/sys-process/cronbase/cronbase-0.3.7-r10.ebuild
+++ b/sys-process/cronbase/cronbase-0.3.7-r10.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit readme.gentoo-r1
+
DESCRIPTION="Base for all cron ebuilds"
HOMEPAGE="https://wiki.gentoo.org/wiki/Cron"
S="${WORKDIR}"
@@ -17,6 +19,15 @@ RDEPEND="
acct-user/cron
"
+DOC_CONTENTS="
+ To add a user to the cron group so it can create cron jobs, run:
+
+ usermod -a -G cron <user>
+
+ For more information, visit the wiki page:
+ https://wiki.gentoo.org/wiki/Cron
+"
+
src_install() {
newsbin "${FILESDIR}"/run-crons-${PV} run-crons
@@ -24,13 +35,9 @@ src_install() {
keepdir /etc/cron.{hourly,daily,weekly,monthly}
keepdir /var/spool/cron/lastrun
+ readme.gentoo_create_doc
}
pkg_postinst() {
- elog "To add a user to the cron group so it can create cron jobs, run:"
- elog
- elog " usermod -a -G cron <user>"
- elog
- elog "For more information, visit the wiki page:"
- elog "https://wiki.gentoo.org/wiki/Cron"
+ readme.gentoo_print_elog
}