summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/parallel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/parallel')
-rw-r--r--sys-process/parallel/Manifest2
-rw-r--r--sys-process/parallel/metadata.xml27
-rw-r--r--sys-process/parallel/parallel-20150522.ebuild44
-rw-r--r--sys-process/parallel/parallel-20150622.ebuild44
4 files changed, 117 insertions, 0 deletions
diff --git a/sys-process/parallel/Manifest b/sys-process/parallel/Manifest
new file mode 100644
index 000000000000..f3fd694884a4
--- /dev/null
+++ b/sys-process/parallel/Manifest
@@ -0,0 +1,2 @@
+DIST parallel-20150522.tar.bz2 1129286 SHA256 4c4a199740189a4a220a10da29fdb33a0b71abef1f253eeb89a28da6f264f306 SHA512 c55f89be6f5ed23295de062392d798a10ecf5dfa89b8b819af50cb1174c33cff9f9633d911c07ffd6126262a8d011c96397aee9be8551948f7247fa4f0f12fd1 WHIRLPOOL 90ce60b9c35db7010553bc040793c5d959cfa57456bf4f0c5b187a7eb88df8b5a8c2dedd47f5973109a54184d81cfc0c406aae48a7dd8d73969b24671401a72c
+DIST parallel-20150622.tar.bz2 1174020 SHA256 963a9c962ac8f4a53535f779ab7a46336dc6e12234d75dc796248bf9117aef48 SHA512 8bafc5f756f015fc5de880c0483d1d863f80a18193bb8660b43a9ee20a47cc4f22f10596a184e45f4d96b1a5d2308060fa01a69fcd747272f5cd207f82b600ec WHIRLPOOL b867730e14068a5af2734bfd6cb68be2d8cb46eb80bbd7170f77bd0e19d53094a1efda8a5805b59319ff93ed38315e233e563601bf6716489f408eb231a0dd5e
diff --git a/sys-process/parallel/metadata.xml b/sys-process/parallel/metadata.xml
new file mode 100644
index 000000000000..7bed4228d018
--- /dev/null
+++ b/sys-process/parallel/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>ryoichiro.suzuki@gmail.com</email>
+ <name>Ryoichiro Suzuki</name>
+</maintainer>
+<maintainer>
+ <email>fauli@gentoo.org</email>
+ <name>Christian Faulhammer (proxy)</name>
+</maintainer>
+<longdescription lang="en">
+GNU parallel is a shell tool for executing jobs in parallel locally or
+using remote machines. A job is typically a single command or a small
+script that has to be run for each of the lines in the input. The
+typical input is a list of files, a list of hosts, a list of users, a
+list of URLs, or a list of tables.
+
+If you use xargs today you will find GNU parallel very easy to use as
+GNU parallel is written to have the same options as xargs. If you
+write loops in shell, you will find GNU parallel may be able to
+replace most of the loops and make them run faster by running several
+jobs in parallel. If you use ppss or pexec you will find GNU parallel
+will often make the command easier to read.
+</longdescription>
+</pkgmetadata>
diff --git a/sys-process/parallel/parallel-20150522.ebuild b/sys-process/parallel/parallel-20150522.ebuild
new file mode 100644
index 000000000000..ce1f22576b77
--- /dev/null
+++ b/sys-process/parallel/parallel-20150522.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="http://www.gnu.org/software/parallel/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/Devel-Size
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO"
+# moreutils for `parallel` and grass for 'sql.1' manpage
+DEPEND="${RDEPEND}
+ !<sys-apps/moreutils-0.45-r1
+ !<sci-geosciences/grass-6.4.1-r1"
+
+DOCS="NEWS README"
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ # See src/Makefile.am for this one:
+ rm -f "${ED}"usr/bin/sem
+ dosym ${PN} /usr/bin/sem
+}
+
+pkg_postinst() {
+ elog "To distribute jobs to remote machines you'll need these dependencies"
+ elog " net-misc/openssh"
+ elog " net-misc/rsync"
+}
diff --git a/sys-process/parallel/parallel-20150622.ebuild b/sys-process/parallel/parallel-20150622.ebuild
new file mode 100644
index 000000000000..c147d204c042
--- /dev/null
+++ b/sys-process/parallel/parallel-20150622.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="http://www.gnu.org/software/parallel/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/Devel-Size
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO"
+# moreutils for `parallel` and grass for 'sql.1' manpage
+DEPEND="${RDEPEND}
+ !<sys-apps/moreutils-0.45-r1
+ !<sci-geosciences/grass-6.4.1-r1"
+
+DOCS="NEWS README"
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ # See src/Makefile.am for this one:
+ rm -f "${ED}"usr/bin/sem
+ dosym ${PN} /usr/bin/sem
+}
+
+pkg_postinst() {
+ elog "To distribute jobs to remote machines you'll need these dependencies"
+ elog " net-misc/openssh"
+ elog " net-misc/rsync"
+}