summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/psinfo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/psinfo')
-rw-r--r--sys-process/psinfo/Manifest1
-rw-r--r--sys-process/psinfo/files/psinfo-0.12-asneeded.patch36
-rw-r--r--sys-process/psinfo/metadata.xml7
-rw-r--r--sys-process/psinfo/psinfo-0.12.ebuild32
4 files changed, 76 insertions, 0 deletions
diff --git a/sys-process/psinfo/Manifest b/sys-process/psinfo/Manifest
new file mode 100644
index 000000000000..95a3a96126ce
--- /dev/null
+++ b/sys-process/psinfo/Manifest
@@ -0,0 +1 @@
+DIST psinfo-0.12.tar.gz 9107 RMD160 24185c1dd77bc8ea81345182895718bc7852fc1d SHA1 991dabc002420bede6c0866109221ee6892ac2ec SHA256 2c1ad9a76eb91c92f79c859b9058f673fabc6cfc2b0a752db392fc5afd8a3aa1
diff --git a/sys-process/psinfo/files/psinfo-0.12-asneeded.patch b/sys-process/psinfo/files/psinfo-0.12-asneeded.patch
new file mode 100644
index 000000000000..97cfd7f817fb
--- /dev/null
+++ b/sys-process/psinfo/files/psinfo-0.12-asneeded.patch
@@ -0,0 +1,36 @@
+ Makefile | 17 ++++++++++-------
+ 1 files changed, 10 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 2964607..fb4ece8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,10 +1,10 @@
+-CC=gcc
+-CFLAGS=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wswitch -Wshadow -Wcast-align -Wno-unused-parameter -Wchar-subscripts -Winline -Wnested-externs -Wredundant-decls
++CC ?=gcc
++CFLAGS ?=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wswitch -Wshadow -Wcast-align -Wno-unused-parameter -Wchar-subscripts -Winline -Wnested-externs -Wredundant-decls
+ INSTALL=install
+-LDFLAGS=
++LDFLAGS ?=
+ SOURCES=psinfo.c
+ EXECUTABLE=psinfo
+-TARGETDIR=/usr/local/bin
++TARGETDIR=/usr/bin
+
+ all: $(EXECUTABLE)
+
+@@ -12,7 +12,10 @@ clean:
+ rm -f $(EXECUTABLE)
+
+ install: $(EXECUTABLE)
+- $(INSTALL) -m 755 psinfo $(TARGETDIR)
++ $(INSTALL) -D -m 755 psinfo $(DESTDIR)/$(TARGETDIR)/$(EXECUTABLE)
+
+-$(EXECUTABLE): $(SOURCES)
+- $(CC) $(CFLAGS) -o $@ $(SOURCES) $(LDFLAGS)
++$(EXECUTABLE): psinfo.o
++ $(CC) $(LDFLAGS) -o $@ psinfo.o
++
++psinfo.o: psinfo.c
++ $(CC) $(CFLAGS) -c psinfo.c
diff --git a/sys-process/psinfo/metadata.xml b/sys-process/psinfo/metadata.xml
new file mode 100644
index 000000000000..dc06c49f3397
--- /dev/null
+++ b/sys-process/psinfo/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-process/psinfo/psinfo-0.12.ebuild b/sys-process/psinfo/psinfo-0.12.ebuild
new file mode 100644
index 000000000000..7bccc722826b
--- /dev/null
+++ b/sys-process/psinfo/psinfo-0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Process information and statistics using the kernel /proc interface"
+HOMEPAGE="http://www.ward.nu/computer/psinfo/"
+SRC_URI="http://www.ward.nu/computer/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare () {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ tc-export CC
+}
+
+#src_compile() {
+# emake \
+# CFLAGS="${CFLAGS}" \
+# CC=$(tc-getCC)
+#}
+
+#src_install() {
+# dobin ${PN}
+# dodoc README
+#}