summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/dspam-web
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/dspam-web')
-rw-r--r--www-apps/dspam-web/Manifest1
-rw-r--r--www-apps/dspam-web/dspam-web-3.10.1.ebuild71
-rw-r--r--www-apps/dspam-web/files/postinst-en.txt32
-rw-r--r--www-apps/dspam-web/files/setperms9
-rw-r--r--www-apps/dspam-web/metadata.xml6
5 files changed, 119 insertions, 0 deletions
diff --git a/www-apps/dspam-web/Manifest b/www-apps/dspam-web/Manifest
new file mode 100644
index 000000000000..14533387efa0
--- /dev/null
+++ b/www-apps/dspam-web/Manifest
@@ -0,0 +1 @@
+DIST dspam-3.10.1.tar.gz 1044198 RMD160 f7022c10c7555d8a05e5bacb5804b3dc29f96066 SHA1 dfd78c9f696470077d4e2e2b52f1f42f90ac52cc SHA256 359d9f58564a87da131b8390d0eeecae4aa40d22ff74b97256d46835a2474063
diff --git a/www-apps/dspam-web/dspam-web-3.10.1.ebuild b/www-apps/dspam-web/dspam-web-3.10.1.ebuild
new file mode 100644
index 000000000000..53e9c89a74c7
--- /dev/null
+++ b/www-apps/dspam-web/dspam-web-3.10.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit webapp
+
+DESCRIPTION="Web based administration and user controls for dspam"
+HOMEPAGE="http://dspam.nuclearelephant.com/"
+SRC_URI="http://dspam.nuclearelephant.com/sources/dspam-${PV}.tar.gz"
+
+LICENSE="AGPL-3"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND=">=mail-filter/dspam-${PV}[-user-homedirs]
+ dev-perl/GD[png]
+ dev-perl/GD-Graph3d
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil"
+
+need_httpd_cgi
+
+# some FHS-like structure
+HOMEDIR="/var/spool/dspam"
+CONFDIR="/etc/mail/dspam"
+
+S="${WORKDIR}/dspam-${PV}"
+
+src_configure() {
+ econf \
+ --with-dspam-home=${HOMEDIR} \
+ --sysconfdir=${CONFDIR}
+}
+
+src_compile() {
+ cd webui
+ default
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd webui
+ insinto "${MY_HTDOCSDIR}"
+ insopts -m644
+ doins htdocs/*.{css,gif}
+ insinto "${MY_CGIBINDIR}/templates"
+ doins cgi-bin/templates/*.html
+ insinto "${MY_CGIBINDIR}"
+ doins cgi-bin/{admins,configure.pl,default.prefs,rgb.txt,*.cgi}
+
+ webapp_configfile "${MY_CGIBINDIR}"/{admins,configure.pl,default.prefs,rgb.txt}
+
+ webapp_hook_script "${FILESDIR}/setperms"
+ webapp_postinst_txt en "${FILESDIR}/postinst-en.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn "If you're using apache dspam-web's config requires the scripts in the cgi-bin"
+ ewarn "to be run as dspam:dspam. You will have to put a global SuexecUserGroup"
+ ewarn "declaration in the main server config which will force everything in cgi-bin"
+ ewarn "to run as dspam:dspam."
+ ewarn "You should use a dedicated virtual host for this application or at least"
+ ewarn "one that don't have any other cgi scripts."
+ ewarn
+ webapp_pkg_postinst
+}
diff --git a/www-apps/dspam-web/files/postinst-en.txt b/www-apps/dspam-web/files/postinst-en.txt
new file mode 100644
index 000000000000..500f5002abc2
--- /dev/null
+++ b/www-apps/dspam-web/files/postinst-en.txt
@@ -0,0 +1,32 @@
+Define your virtual host like this:
+<VirtualHost *:80>
+ DocumentRoot ${VHOST_HTDOCSDIR}
+ ServerName ${VHOST_HOSTNAME}
+
+ #Use dspam.cgi as main index
+ RewriteEngine On
+ RewriteRule ^/?$ /cgi-bin/dspam.cgi [redirect,last]
+
+ SuexecUserGroup dspam dspam
+ ScriptAlias /cgi-bin/ ${VHOST_CGIBINDIR}/
+
+ <Directory "${VHOST_CGIBINDIR}">
+ Options FollowSymLinks ExecCGI
+ SetHandler cgi-script
+
+ AllowOverride None
+ Order deny,allow
+ Allow from all
+
+ AuthType basic
+ AuthName "DSPAM Control Center"
+ #For those lucky enough to have a LDAP authentication database
+ AuthLDAPURL ldap://localhost:389/ou=People,dc=yourdomain,dc=com?uid?sub?(objectClass=posixAccount)
+ Require valid-user
+ </Directory>
+</VirtualHost>
+
+The configuration files are:
+ - ${VHOST_CGIBINDIR}/configure.pl
+ - ${VHOST_CGIBINDIR}/admins (super-users of this service)
+ - ${VHOST_CGIBINDIR}/default.prefs (not used by those who use MySQL or PostgreSQL backend)
diff --git a/www-apps/dspam-web/files/setperms b/www-apps/dspam-web/files/setperms
new file mode 100644
index 000000000000..91c4fcf10fdf
--- /dev/null
+++ b/www-apps/dspam-web/files/setperms
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if [[ "$1" = "install" ]]; then
+ chgrp -R dspam "${VHOST_CGIBINDIR}"
+ chown dspam "${VHOST_CGIBINDIR}" "${VHOST_CGIBINDIR}"/*.cgi
+ chmod -R ugo+r "${VHOST_CGIBINDIR}"
+ chmod 0755 "${VHOST_CGIBINDIR}"
+ chmod ugo+rx "${VHOST_CGIBINDIR}"/*.cgi
+fi
diff --git a/www-apps/dspam-web/metadata.xml b/www-apps/dspam-web/metadata.xml
new file mode 100644
index 000000000000..4f3fa398a3f9
--- /dev/null
+++ b/www-apps/dspam-web/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+<longdescription>Web Administrative interface for a statistical-algorithmic hybrid anti-spam filter</longdescription>
+</pkgmetadata>