summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2024-12-16 18:54:20 +0100
committerViorel Munteanu <ceamac@gentoo.org>2024-12-16 20:05:35 +0200
commit4110f7d8606f14bfa7573e1c547f3ec1585011ea (patch)
treea7917edbba6953e6c9649f105a7bdbcb9085ea1b /www-apps/rutorrent
parentsys-cluster/kube-scheduler: add 1.30.8 (diff)
downloadgentoo-4110f7d8606f14bfa7573e1c547f3ec1585011ea.tar.gz
gentoo-4110f7d8606f14bfa7573e1c547f3ec1585011ea.tar.bz2
gentoo-4110f7d8606f14bfa7573e1c547f3ec1585011ea.zip
www-apps/rutorrent: add 5.1.4
Signed-off-by: Henning Schild <henning@hennsch.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/rutorrent')
-rw-r--r--www-apps/rutorrent/Manifest1
-rw-r--r--www-apps/rutorrent/rutorrent-5.1.4.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 52e2392b190f..95036779a477 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,2 +1,3 @@
DIST rutorrent-4.3.10.tar.gz 2378291 BLAKE2B 2e676024e4b8fdec2a3e8b52715348dc7f4ae38adbdffb69e4f22b711d02eb49ce4de30e5e30e6a620819c39a6576c14b4fade6bc3b52a9212f1a96b23d96b99 SHA512 34a8f4b0bca721deb1d1fd017eed3cc722a785acafe2ca99ee56691028fce1fd92d069f69e2a4be18bef059c4c3f8a9d5eea54b86b9f6ed81401526337d7c856
DIST rutorrent-5.1.3.tar.gz 2694675 BLAKE2B 0476db6f725c2bb9edd1b3b5f780dd4e693b823b6e21eb145d6a37c7929c56400a269d91a60ce8f1f7163338a90abbe6bc23c52dbad242ffa84fc9d7978433cc SHA512 08b2ad655dff9027cac22f975b89ab34cf66b1e833d68e76a87309cbb5671ba0d979fd53ff2e9cc93eaf49b9d53198e5d83336fca10b16120d8fc0834cbdeb24
+DIST rutorrent-5.1.4.tar.gz 2694610 BLAKE2B aa02dc87dc4f228aa4ac24f7dea8d5c80500d275b8a60f29bea8098a784c413eac8b902d55395dfc51d83f6c0634dcf61e0c69a86732f69d30cde55135896b0d SHA512 fc318ece9199d203589cb28d0cf4565b7ce2288d00862c61d1ddcc713a77cc0682f446c983a81f59029c61ce09c5811871854a9c017864a657c9a4a27d039919
diff --git a/www-apps/rutorrent/rutorrent-5.1.4.ebuild b/www-apps/rutorrent/rutorrent-5.1.4.ebuild
new file mode 100644
index 000000000000..97453fadf5c8
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-5.1.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}