summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-11 04:50:08 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-11 05:07:23 +0100
commit832063fcffe02eb04f68486146ceb7b214197961 (patch)
tree756ae9509b83cb6250a760372336a84730cbb29c /www-apps
parentdev-python/sphinxcontrib-log-cabinet: Enable py3.13 (diff)
downloadgentoo-832063fcffe02eb04f68486146ceb7b214197961.tar.gz
gentoo-832063fcffe02eb04f68486146ceb7b214197961.tar.bz2
gentoo-832063fcffe02eb04f68486146ceb7b214197961.zip
Rename dev-python/{jinja → jinja2}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nikola/nikola-8.2.4-r1.ebuild4
-rw-r--r--www-apps/nikola/nikola-8.3.0.ebuild4
-rw-r--r--www-apps/roundup/roundup-2.2.0.ebuild6
-rw-r--r--www-apps/roundup/roundup-2.3.0.ebuild2
4 files changed, 8 insertions, 8 deletions
diff --git a/www-apps/nikola/nikola-8.2.4-r1.ebuild b/www-apps/nikola/nikola-8.2.4-r1.ebuild
index 68ff3f47c2d0..f933e003e451 100644
--- a/www-apps/nikola/nikola-8.2.4-r1.ebuild
+++ b/www-apps/nikola/nikola-8.2.4-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9,10,11} )
+PYTHON_COMPAT=( python3_{10,11} )
DISTUTILS_USE_PEP517=setuptools
inherit bash-completion-r1 distutils-r1 optfeature pypi
@@ -62,7 +62,7 @@ pkg_postinst() {
optfeature "chart generation" dev-python/pygal
optfeature "hyphenation support" dev-python/pyphen
optfeature "notebook compilation and LESS support" dev-python/ipython
- optfeature "alternative templating engine to Mako" dev-python/jinja
+ optfeature "alternative templating engine to Mako" dev-python/jinja2
optfeature "built-in web server support" dev-python/aiohttp
optfeature "monitoring file system events" dev-python/watchdog
optfeature "extracting metadata from web media links" dev-python/micawber
diff --git a/www-apps/nikola/nikola-8.3.0.ebuild b/www-apps/nikola/nikola-8.3.0.ebuild
index 609c01678bc0..e9ae1c7c0003 100644
--- a/www-apps/nikola/nikola-8.3.0.ebuild
+++ b/www-apps/nikola/nikola-8.3.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9,10,11,12} )
+PYTHON_COMPAT=( python3_{10,11,12} )
DISTUTILS_USE_PEP517=setuptools
inherit bash-completion-r1 distutils-r1 optfeature pypi
@@ -60,7 +60,7 @@ pkg_postinst() {
optfeature "chart generation" dev-python/pygal
optfeature "hyphenation support" dev-python/pyphen
optfeature "notebook compilation and LESS support" dev-python/ipython
- optfeature "alternative templating engine to Mako" dev-python/jinja
+ optfeature "alternative templating engine to Mako" dev-python/jinja2
optfeature "built-in web server support" dev-python/aiohttp
optfeature "monitoring file system events" dev-python/watchdog
optfeature "extracting metadata from web media links" dev-python/micawber
diff --git a/www-apps/roundup/roundup-2.2.0.ebuild b/www-apps/roundup/roundup-2.2.0.ebuild
index d82993a48cd1..155a65a9c527 100644
--- a/www-apps/roundup/roundup-2.2.0.ebuild
+++ b/www-apps/roundup/roundup-2.2.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 pypi
@@ -15,7 +15,7 @@ KEYWORDS="amd64 ~ppc sparc x86"
IUSE="+tz sqlite mysql postgres xapian whoosh ssl jinja pyjwt markdown"
RDEPEND="
- jinja? ( dev-python/jinja[$PYTHON_USEDEP] )
+ jinja? ( dev-python/jinja2[$PYTHON_USEDEP] )
markdown? (
|| (
dev-python/markdown[$PYTHON_USEDEP]
diff --git a/www-apps/roundup/roundup-2.3.0.ebuild b/www-apps/roundup/roundup-2.3.0.ebuild
index 05d61ddbcf9c..060a507cfcee 100644
--- a/www-apps/roundup/roundup-2.3.0.ebuild
+++ b/www-apps/roundup/roundup-2.3.0.ebuild
@@ -16,7 +16,7 @@ KEYWORDS="amd64 ~ppc sparc x86"
IUSE="+tz sqlite mysql postgres xapian whoosh ssl jinja pyjwt markdown test"
RDEPEND="
- jinja? ( dev-python/jinja[${PYTHON_USEDEP}] )
+ jinja? ( dev-python/jinja2[${PYTHON_USEDEP}] )
markdown? (
|| (
dev-python/markdown[${PYTHON_USEDEP}]