summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2025-01-16 17:25:44 +1000
committerMatt Jolly <kangie@gentoo.org>2025-01-16 18:00:18 +1000
commite16dae06c50773525f42c6617a4fdfb69d6b8598 (patch)
tree309df88b6d02eae2ec69e557c3b2a3ad1dcfd122 /www-client/chromium
parentwww-client/chromium: keyword 132.0.6834.83 for ~ppc64 (diff)
downloadgentoo-e16dae06c50773525f42c6617a4fdfb69d6b8598.tar.gz
gentoo-e16dae06c50773525f42c6617a4fdfb69d6b8598.tar.bz2
gentoo-e16dae06c50773525f42c6617a4fdfb69d6b8598.zip
www-client/chromium: M133: sync ppc64 codepath with M132
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-133.0.6943.6.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/www-client/chromium/chromium-133.0.6943.6.ebuild b/www-client/chromium/chromium-133.0.6943.6.ebuild
index d52caeb0683f..73e6948b0e85 100644
--- a/www-client/chromium/chromium-133.0.6943.6.ebuild
+++ b/www-client/chromium/chromium-133.0.6943.6.ebuild
@@ -47,7 +47,7 @@ SRC_URI="https://chromium-tarballs.distfiles.gentoo.org/${P}-linux.tar.xz
https://chromium-fonts.storage.googleapis.com/${TEST_FONT} -> chromium-testfonts-${TEST_FONT:0:10}.tar.gz
)
ppc64? (
- https://gitlab.solidsilicon.io/public-development/open-source/chromium/openpower-patches/-/archive/${PPC64_HASH}/openpower-patches-${PPC64_HASH}.tar.bz2 -> chromium-openpower-${PPC64_HASH:0:10}.tar.bz2
+ https://gitlab.raptorengineering.com/raptor-engineering-public/chromium/openpower-patches/-/archive/${PPC64_HASH}/openpower-patches-${PPC64_HASH}.tar.bz2 -> chromium-openpower-${PPC64_HASH:0:10}.tar.bz2
)
pgo? ( https://github.com/elkablo/chromium-profiler/releases/download/v0.2/chromium-profiler-0.2.tar )"
@@ -408,8 +408,10 @@ src_prepare() {
local patchset_dir="${WORKDIR}/openpower-patches-${PPC64_HASH}/patches"
# patch causes build errors on 4K page systems (https://bugs.gentoo.org/show_bug.cgi?id=940304)
local page_size_patch="ppc64le/third_party/use-sysconf-page-size-on-ppc64.patch"
- # Apply the OpenPOWER patches (check for page size)
- openpower_patches=( $(grep -E "^ppc64le|^upstream" "${patchset_dir}/series" | grep -v "${page_size_patch}" || die) )
+ local isa_3_patch="ppc64le/core/baseline-isa-3-0.patch"
+ # Apply the OpenPOWER patches (check for page size and isa 3.0)
+ openpower_patches=( $(grep -E "^ppc64le|^upstream" "${patchset_dir}/series" | grep -v "${page_size_patch}" |
+ grep -v "${isa_3_patch}" || die) )
for patch in "${openpower_patches[@]}"; do
PATCHES+=( "${patchset_dir}/${patch}" )
done
@@ -418,7 +420,7 @@ src_prepare() {
fi
# We use vsx3 as a proxy for 'want isa3.0' (POWER9)
if use cpu_flags_ppc_vsx3 ; then
- PATCHES+=( "${patchset_dir}/ppc64le/core/baseline-isa-3-0.patch" )
+ PATCHES+=( +"${patchset_dir}/${isa_3_patch}" )
fi
fi