summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-21 16:46:40 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-21 16:52:56 -0400
commitb5b300aad5b4c95789c941d23b528de6f7bb89e7 (patch)
tree2545d89e52d324c1991162efae76ea157b3d0383 /www-client/netsurf/files
parentnet-libs/libhubbub: remove old (diff)
downloadgentoo-b5b300aad5b4c95789c941d23b528de6f7bb89e7.tar.gz
gentoo-b5b300aad5b4c95789c941d23b528de6f7bb89e7.tar.bz2
gentoo-b5b300aad5b4c95789c941d23b528de6f7bb89e7.zip
www-client/netsurf: bump to 3.8
I had to drop gstreamer because it depends on a vulnerable version. Closes: https://bugs.gentoo.org/636224 Closes: https://bugs.gentoo.org/662230 Closes: https://bugs.gentoo.org/629204 Closes: https://bugs.gentoo.org/641846 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'www-client/netsurf/files')
-rw-r--r--www-client/netsurf/files/netsurf-3.8-CFLAGS.patch79
-rw-r--r--www-client/netsurf/files/netsurf-3.8-pdf-writer.patch86
2 files changed, 165 insertions, 0 deletions
diff --git a/www-client/netsurf/files/netsurf-3.8-CFLAGS.patch b/www-client/netsurf/files/netsurf-3.8-CFLAGS.patch
new file mode 100644
index 000000000000..c52422dcb92b
--- /dev/null
+++ b/www-client/netsurf/files/netsurf-3.8-CFLAGS.patch
@@ -0,0 +1,79 @@
+diff --git a/Makefile.defaults b/Makefile.defaults
+index 51090109e..f1ec46f73 100644
+--- a/Makefile.defaults
++++ b/Makefile.defaults
+@@ -114,12 +114,6 @@ NETSURF_USE_SANITIZERS := NO
+ # But recover after sanitizer failure
+ NETSURF_RECOVER_SANITIZERS := YES
+
+-# Initial CFLAGS. Optimisation level etc. tend to be target specific.
+-CFLAGS :=
+-
+-# Initial CXXFLAGS. Optimisation level etc. tend to be target specific.
+-CXXFLAGS :=
+-
+ # Default installation/execution prefix
+ PREFIX ?= /usr/local
+
+diff --git a/frontends/framebuffer/Makefile b/frontends/framebuffer/Makefile
+index bdedd903b..35179138a 100644
+--- a/frontends/framebuffer/Makefile
++++ b/frontends/framebuffer/Makefile
+@@ -20,7 +20,7 @@ CFLAGS += '-DNETSURF_FB_FONT_MONOSPACE_BOLD="$(NETSURF_FB_FONT_MONOSPACE_BOLD)"'
+ CFLAGS += '-DNETSURF_FB_FONT_CURSIVE="$(NETSURF_FB_FONT_CURSIVE)"'
+ CFLAGS += '-DNETSURF_FB_FONT_FANTASY="$(NETSURF_FB_FONT_FANTASY)"'
+
+-CFLAGS += -std=c99 -g -Dsmall \
++CFLAGS += -std=c99 -Dsmall \
+ -D_BSD_SOURCE \
+ -D_DEFAULT_SOURCE \
+ -D_XOPEN_SOURCE=600 \
+diff --git a/frontends/framebuffer/Makefile.defaults b/frontends/framebuffer/Makefile.defaults
+index cc712e992..f132c97d6 100644
+--- a/frontends/framebuffer/Makefile.defaults
++++ b/frontends/framebuffer/Makefile.defaults
+@@ -3,7 +3,7 @@
+ # ----------------------------------------------------------------------------
+
+ # Optimisation levels
+-CFLAGS += -O2
++CFLAGS +=
+
+ # Framebuffer default surface provider.
+ # Valid values are: x, sdl, linux, vnc, able,
+diff --git a/frontends/gtk/Makefile b/frontends/gtk/Makefile
+index ec60ce70c..04af6df8f 100644
+--- a/frontends/gtk/Makefile
++++ b/frontends/gtk/Makefile
+@@ -33,7 +33,7 @@ GTKDEPFLAGS += -DGTK_DISABLE_DEPRECATED
+ endif
+
+
+-GTKCFLAGS := -std=c99 -Dgtk -Dnsgtk -g \
++GTKCFLAGS := -std=c99 -Dgtk -Dnsgtk \
+ $(GTKDEPFLAGS) \
+ -D_BSD_SOURCE \
+ -D_DEFAULT_SOURCE \
+diff --git a/frontends/gtk/Makefile.defaults b/frontends/gtk/Makefile.defaults
+index a98043eb9..bb5371230 100644
+--- a/frontends/gtk/Makefile.defaults
++++ b/frontends/gtk/Makefile.defaults
+@@ -39,4 +39,4 @@ NETSURF_FS_BACKING_STORE := YES
+ NETSURF_GTK_MAJOR ?= 2
+
+ # Optimisation levels
+-CFLAGS += -O2
++CFLAGS +=
+diff --git a/test/Makefile b/test/Makefile
+index 4f9dd22c9..8bec9b88a 100644
+--- a/test/Makefile
++++ b/test/Makefile
+@@ -134,7 +134,7 @@ ifneq ($(CC_MAJOR),2)
+ COMMON_WARNFLAGS += -Wno-unused-parameter
+ endif
+
+-BASE_TESTCFLAGS := -std=c99 -g \
++BASE_TESTCFLAGS := -std=c99 \
+ $(COMMON_WARNFLAGS) \
+ -D_DEFAULT_SOURCE \
+ -D_POSIX_C_SOURCE=200809L \
diff --git a/www-client/netsurf/files/netsurf-3.8-pdf-writer.patch b/www-client/netsurf/files/netsurf-3.8-pdf-writer.patch
new file mode 100644
index 000000000000..e9c2420a33fd
--- /dev/null
+++ b/www-client/netsurf/files/netsurf-3.8-pdf-writer.patch
@@ -0,0 +1,86 @@
+diff --git a/desktop/font_haru.c b/desktop/font_haru.c
+index 4ee9824f0..3304ba82a 100644
+--- a/desktop/font_haru.c
++++ b/desktop/font_haru.c
+@@ -37,7 +37,7 @@
+ #include <hpdf.h>
+
+ #include "utils/nsoption.h"
+-#include "desktop/save_pdf/font_haru.h"
++#include "desktop/font_haru.h"
+ #include "desktop/font.h"
+ #include "utils/log.h"
+
+diff --git a/desktop/save_pdf.c b/desktop/save_pdf.c
+index 889190089..9e6265cfb 100644
+--- a/desktop/save_pdf.c
++++ b/desktop/save_pdf.c
+@@ -60,6 +60,8 @@
+ #include "utils/useragent.h"
+ #include "content/hlcache.h"
+ #include "utils/nsoption.h"
++#include "desktop/gui_misc.h"
++#include "desktop/gui_internal.h"
+ #include "netsurf/bitmap.h"
+
+ #include "netsurf/plotters.h"
+@@ -455,11 +457,6 @@ HPDF_Image pdf_extract_image(struct bitmap *bitmap)
+
+ switch(content_get_type(content)){
+ /*Handle "embeddable" types of images*/
+- case CONTENT_JPEG:
+- image = HPDF_LoadJpegImageFromMem(pdf_doc,
+- (const HPDF_BYTE *) source_data,
+- source_size);
+- break;
+
+ /*Disabled until HARU PNG support will be more stable.
+
+@@ -706,7 +703,7 @@ bool pdf_begin(struct print_settings *print_settings)
+
+
+ #ifndef PDF_DEBUG
+- if (option_enable_PDF_compression)
++ if (nsoption_bool(enable_PDF_compression))
+ HPDF_SetCompressionMode(pdf_doc, HPDF_COMP_ALL); /*Compression on*/
+ #endif
+ HPDF_SetInfoAttr(pdf_doc, HPDF_INFO_CREATOR, user_agent_string());
+@@ -780,7 +777,7 @@ void pdf_end(void)
+ assert(settings->output != NULL);
+
+ /*Encryption on*/
+- if (option_enable_PDF_password)
++ if (nsoption_bool(enable_PDF_password))
+ guit->misc->pdf_password(&owner_pass, &user_pass,
+ (void *)settings->output);
+ else
+@@ -795,7 +792,7 @@ nserror save_pdf(const char *path)
+ {
+ nserror res = NSERROR_OK;
+
+- if (option_enable_PDF_password && owner_pass != NULL ) {
++ if (nsoption_bool(enable_PDF_password) && owner_pass != NULL ) {
+ HPDF_SetPassword(pdf_doc, owner_pass, user_pass);
+ HPDF_SetEncryptionMode(pdf_doc, HPDF_ENCRYPT_R3, 16);
+ free(owner_pass);
+diff --git a/frontends/gtk/scaffolding.c b/frontends/gtk/scaffolding.c
+index 8c46fd884..748518fdc 100644
+--- a/frontends/gtk/scaffolding.c
++++ b/frontends/gtk/scaffolding.c
+@@ -853,14 +853,14 @@ MULTIHANDLER(pdf)
+
+ free(url_name);
+
+- strncpy(dirname, option_downloads_directory, PATH_MAX);
++ strncpy(dirname, nsoption_charp(downloads_directory), PATH_MAX);
+ strncat(dirname, "/", PATH_MAX - strlen(dirname));
+ dirname[PATH_MAX - 1] = '\0';
+
+ /* this way the scale used by PDF functions is synchronised with that
+ * used by the all-purpose print interface
+ */
+- haru_nsfont_set_scale((float)option_export_scale / 100);
++ haru_nsfont_set_scale((float)nsoption_int(export_scale) / 100);
+
+ save_dialog = gtk_file_chooser_dialog_new("Export to PDF", g->window,
+ GTK_FILE_CHOOSER_ACTION_SAVE,