summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-04-14 13:50:01 -0700
committerZac Medico <zmedico@gentoo.org>2024-04-14 13:50:13 -0700
commitd94b9a7807941794cb98cdd0158a5489126f35fd (patch)
tree3ac26bed08e083364b8f8db62a638b0b9024e0e8 /www-servers
parentapp-admin/consul-template: drop 0.29.5 (diff)
downloadgentoo-d94b9a7807941794cb98cdd0158a5489126f35fd.tar.gz
gentoo-d94b9a7807941794cb98cdd0158a5489126f35fd.tar.bz2
gentoo-d94b9a7807941794cb98cdd0158a5489126f35fd.zip
www-servers/caddy: drop 2.7.6
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/caddy/Manifest1
-rw-r--r--www-servers/caddy/caddy-2.7.6.ebuild94
2 files changed, 0 insertions, 95 deletions
diff --git a/www-servers/caddy/Manifest b/www-servers/caddy/Manifest
index 7c07f276e8f8..73920dd08a5d 100644
--- a/www-servers/caddy/Manifest
+++ b/www-servers/caddy/Manifest
@@ -1,4 +1,3 @@
-DIST caddy-2.7.6-deps.tar.xz 128958740 BLAKE2B ffbe682df64a88dac9f50e9712f1d6697e58f2d9854c270321f7a0325f0b5ead7f93316756136a4435b70c5e08742c7130ce507ee4aa4696f4fb906f4eba8754 SHA512 f467144e235e09a7718cffe5ed3c40ec2d63038a6a948fe4f85d34717877af8a9959ef7e2c3ac32fd0cce522d693ccac883877f061f5cefc9512f7eed556b336
DIST caddy-2.7.6-docs.tar.gz 24583 BLAKE2B d3dbbb701d86cbfaf538f10911fdd3613b8c3c0f49ef9e229487d2a4fcef9eff79b56e9852d5c1ccd5a8d1d1898861fc8183c343c129901562b03a9092af9e61 SHA512 62e534d41e714b47265fd8089ad9e03a1a89903460976d8af27fa5f71173e076bab8574282213595e495be701b769e1a70ff9e7ec9576fbf8e821e672207faa5
DIST caddy-2.7.6-r1-deps.tar.xz 129331604 BLAKE2B 50b83c012c70637936c83ec765758cdcd80014ca224d76a746de8640a6b36ae15ce11ec57d9fdb20a5f7b3add946209c6dde7bb4e4bd4a47ffe3ffc8971725db SHA512 a4bc56de4f7ec8e9967dde3d7ca4cbb74cba9ce0b8906ffe16f8dae3f52fff1164827942df8154eadbae80cce3ee603535b9135cf8a5126d84a9017e8aece078
DIST caddy-2.7.6-r2-deps.tar.xz 8511804 BLAKE2B ad3c78ee483474754ad83284fabf249c376423217c2929740cd171446d0e755f121e380130c80f291422d39ca69ea7e6ac52f5ce5cdec740616099b665cef5af SHA512 c48d299d9a0b27ebe467f64dc433625de26293674d8153122ad6798a6b95ed4fe55f764a18d3e9211a8e2f966724d20996f1789e2e84dbb0181cfcf5340303fb
diff --git a/www-servers/caddy/caddy-2.7.6.ebuild b/www-servers/caddy/caddy-2.7.6.ebuild
deleted file mode 100644
index cf32d908e71b..000000000000
--- a/www-servers/caddy/caddy-2.7.6.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module systemd shell-completion
-
-DESCRIPTION="Fast and extensible multi-platform HTTP/1-2-3 web server with automatic HTTPS"
-HOMEPAGE="https://caddyserver.com"
-
-if [[ "${PV}" == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/caddyserver/caddy.git"
-else
- SRC_URI="https://github.com/caddyserver/caddy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
- SRC_URI+=" https://github.com/caddyserver/dist/archive/refs/tags/v${PV}.tar.gz -> ${P}-docs.tar.gz"
- KEYWORDS="amd64 arm64 ~loong ~riscv"
-fi
-
-LICENSE="Apache-2.0"
-LICENSE+=" BSD ECL-2.0 MIT CC0-1.0"
-SLOT="0"
-RESTRICT="test"
-RDEPEND="
- acct-user/http
- acct-group/http"
-DEPEND="${RDEPEND}"
-
-FILECAPS=(
- -m 755 'cap_net_bind_service=+ep' usr/bin/"${PN}"
-)
-
-PATCHES=(
- "${FILESDIR}"/remove-binary-altering-commands-2.7.5.patch
-)
-
-src_unpack() {
- if [[ "${PV}" == 9999* ]]; then
- # unpack code
- git-r3_src_unpack
-
- # unpack docs and misc
- EGIT_REPO_URI="https://github.com/caddyserver/dist.git"
- EGIT_CHECKOUT_DIR="${WORKDIR}/dist-${PV}"
- git-r3_src_unpack
-
- go-module_live_vendor
- else
- go-module_src_unpack
- fi
-}
-
-src_prepare(){
- default
- sed -i -e "s|User=caddy|User=http|g;s|Group=caddy|Group=http|g;" ../dist-"${PV}"/init/*service || die
-}
-
-src_compile() {
- # https://github.com/caddyserver/caddy/blob/master/caddy.go#L843
- if [[ ${PV} == 9999* ]]; then
- local CUSTOM_VER="git-$(git rev-parse --short HEAD)"
- else
- local CUSTOM_VER="${PV}"
- fi
-
- ego build -ldflags "-X github.com/caddyserver/caddy/v2.CustomVersion=${CUSTOM_VER}" ./cmd/caddy
- local sh
- for sh in bash fish zsh; do
- ./caddy completion "${sh}" > completion."${sh}" || die
- done
- ./caddy manpage -o manpages || die
-}
-
-src_install() {
- default
-
- dobin "${PN}"
- insinto /etc/"${PN}"
- doins ../dist-"${PV}"/config/Caddyfile
- systemd_dounit ../dist-"${PV}"/init/*.service
- newinitd "${FILESDIR}"/initd-2.7.5 "${PN}"
- newconfd "${FILESDIR}"/confd-2.7.5 "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/logrotated" "${PN}"
- insinto /usr/share/"${PN}"
- doins ../dist-"${PV}"/welcome/index.html
-
- newbashcomp completion.bash "${PN}"
- newfishcomp completion.fish "${PN}".fish
- newzshcomp completion.zsh _"${PN}"
- newdoc ../dist-"${PV}"/init/README.md systemd-services-README.md
- doman manpages/*
-}