summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-01-22 10:44:54 +0100
committerPacho Ramos <pacho@gentoo.org>2022-01-22 10:51:47 +0100
commit00363c6dece2af1f7227d7dcfe4462b5b34a0e0b (patch)
tree9abec68149b75b7bcfe5f91f892f9679dab5f15e /x11-libs
parentdev-libs/folks: Bump to 0.15.4 (diff)
downloadgentoo-00363c6dece2af1f7227d7dcfe4462b5b34a0e0b.tar.gz
gentoo-00363c6dece2af1f7227d7dcfe4462b5b34a0e0b.tar.bz2
gentoo-00363c6dece2af1f7227d7dcfe4462b5b34a0e0b.zip
x11-libs/goffice: Bump to 0.10.51
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/goffice/Manifest1
-rw-r--r--x11-libs/goffice/goffice-0.10.51.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index b0d8c82983da..ef5be53c8ce2 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1,2 +1,3 @@
DIST goffice-0.10.49.tar.xz 2430256 BLAKE2B 64ef27ab729f02b42742b2ae8da43c59b560d016caa707c6dccb3dc6f23eaab13b40367f145b83b1c728c9884dff164118f4a4d6f9ac5accb07596173b127271 SHA512 a185f9fc814ecd2a6e69d026ac150c38e30e1a440f7640bcfc3bfd1939b924621eabf2faafa2837e2d1835418f5481a0d0d7980f4a669e7ca1b93907b17a303a
DIST goffice-0.10.50.tar.xz 2430608 BLAKE2B 0b06da8d58c4407465266f8c5421331d5d05731038bca191afdd1823950dde07439d458c0ddb93e0641ff81e727f055313be3c8af29bdf32214ed8b2c2cafc0b SHA512 1117540d9162d45059150281b03941ff9b6df1929dcbd7e5aa6e28010d3bb5a46902c30b6f1d35fd5b60f9afe73b58f132aa686aa1712332ea18635d5a79bd0c
+DIST goffice-0.10.51.tar.xz 2432992 BLAKE2B 89da3c4707516884c13fed15f3ea04a60f871888469c7a119d42654f1470001bbcbc5a67bd46fcdb6af458ded0cb951a132cc60cd7861d6ebb762bdab1cf4311 SHA512 4d0e6c4c4c6c2f18b1e22c2b24d4034a693c1f6698e58589b83a956b9ff52d1ce05f1e7fdaab5c22c8c6f1d93b53c202f2505bdf9fddba646ef34c75fdb2f520
diff --git a/x11-libs/goffice/goffice-0.10.51.ebuild b/x11-libs/goffice/goffice-0.10.51.ebuild
new file mode 100644
index 000000000000..2bcc131cd893
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.51.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org libtool
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libxml2-2.4.12:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=x11-libs/cairo-1.10:=[svg]
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/pango-1.24:=
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:=
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}
+
+src_install() {
+ default
+ dodoc MAINTAINERS
+
+ find "${ED}" -name '*.la' -delete || die
+}