summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbmail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbmail')
-rw-r--r--x11-misc/bbmail/Manifest1
-rw-r--r--x11-misc/bbmail/bbmail-0.9.3.ebuild33
-rw-r--r--x11-misc/bbmail/files/bbmail-0.9.3-gcc4.3.patch45
-rw-r--r--x11-misc/bbmail/files/bbmail-0.9.3-gcc4.4.patch89
-rw-r--r--x11-misc/bbmail/metadata.xml13
5 files changed, 181 insertions, 0 deletions
diff --git a/x11-misc/bbmail/Manifest b/x11-misc/bbmail/Manifest
new file mode 100644
index 000000000000..521ed79d72e2
--- /dev/null
+++ b/x11-misc/bbmail/Manifest
@@ -0,0 +1 @@
+DIST bbmail-0.9.3.tar.gz 186433 SHA256 e992f83d758215e3331f7bfcb5431b6cc8988bc542907de1bca6fe3c8ae9233e
diff --git a/x11-misc/bbmail/bbmail-0.9.3.ebuild b/x11-misc/bbmail/bbmail-0.9.3.ebuild
new file mode 100644
index 000000000000..ab3d3ce8e92d
--- /dev/null
+++ b/x11-misc/bbmail/bbmail-0.9.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="blackbox mail notification"
+HOMEPAGE="http://sourceforge.net/projects/bbtools"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-wm/blackbox
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch \
+ "${FILESDIR}"/${P}-gcc4.4.patch
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin scripts/bbmailparsefm.pl
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README TODO
+}
diff --git a/x11-misc/bbmail/files/bbmail-0.9.3-gcc4.3.patch b/x11-misc/bbmail/files/bbmail-0.9.3-gcc4.3.patch
new file mode 100644
index 000000000000..442c68f3ce8e
--- /dev/null
+++ b/x11-misc/bbmail/files/bbmail-0.9.3-gcc4.3.patch
@@ -0,0 +1,45 @@
+Reason: Fix compile with gcc 4.3 and glibc 2.8.
+Upstream: Sent, http://sourceforge.net/tracker/index.php?func=detail&aid=2116825&group_id=54703&atid=474517
+--- bbmail-0.9.3.orig/src/baseresource.cpp 2008-09-17 22:39:58.000000000 +0200
++++ bbmail-0.9.3/src/baseresource.cpp 2008-09-17 22:44:16.000000000 +0200
+@@ -20,6 +20,7 @@
+ //
+
+ #include <string>
++#include <cstring>
+ #include "baseresource.h"
+ #include <stdio.h>
+ #include "Menu.hh"
+--- bbmail-0.9.3.orig/src/bbmail.cpp 2008-09-17 22:39:58.000000000 +0200
++++ bbmail-0.9.3/src/bbmail.cpp 2008-09-17 22:43:49.000000000 +0200
+@@ -22,6 +22,8 @@
+ #include "bbmail.h"
+ #include "config.h"
+ #include <string>
++#include <cstring>
++
+
+ extern "C" {
+ #include <utime.h>
+--- bbmail-0.9.3.orig/src/main.cpp 2008-09-17 22:39:58.000000000 +0200
++++ bbmail-0.9.3/src/main.cpp 2008-09-17 22:42:09.000000000 +0200
+@@ -23,6 +23,8 @@
+ #include "main.h"
+ #include "config.h"
+
++#include <cstring>
++
+ Configuration::Configuration(int iargc, char **iargv)
+ {
+ withdrawn = false;
+--- bbmail-0.9.3.orig/src/resource.cpp 2008-09-17 22:39:58.000000000 +0200
++++ bbmail-0.9.3/src/resource.cpp 2008-09-17 22:44:36.000000000 +0200
+@@ -23,6 +23,8 @@
+ #include "resource.h"
+ #include "blackboxstyle.h"
+
++#include <cstring>
++
+ Resource::Resource(ToolWindow *toolwindow, const std::string &rc_file):
+ BaseResource(*toolwindow, toolwindow->getCurrentScreen(), rc_file),
+ spoolfile(0),
diff --git a/x11-misc/bbmail/files/bbmail-0.9.3-gcc4.4.patch b/x11-misc/bbmail/files/bbmail-0.9.3-gcc4.4.patch
new file mode 100644
index 000000000000..d0f93d921d97
--- /dev/null
+++ b/x11-misc/bbmail/files/bbmail-0.9.3-gcc4.4.patch
@@ -0,0 +1,89 @@
+diff -ur bbmail-0.9.3.orig/configure.ac bbmail-0.9.3/configure.ac
+--- bbmail-0.9.3.orig/configure.ac 2007-12-03 23:04:11.000000000 +0200
++++ bbmail-0.9.3/configure.ac 2009-07-30 19:24:12.000000000 +0300
+@@ -9,13 +9,11 @@
+ AC_DEFUN(AC_SET_DEBUG,
+ [
+ test "$CXXFLAGS" = "" && CXXFLAGS="-g -Wall -DDEBUG"
+- test "$LDFLAGS" = "" && LDFLAGS=""
+ ])
+
+ AC_DEFUN(AC_SET_NODEBUG,
+ [
+- test "$CXXFLAGS" = "" && CXXFLAGS="-O2 -Wall"
+- test "$LDFLAGS" = "" && LDFLAGS="-s"
++ test "$CXXFLAGS" = "" && CXXFLAGS="-Wall"
+ ])
+
+
+@@ -46,9 +44,9 @@
+
+ CFLAGS="$CFLAGS $X_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
++LIBS="$X_LIBS $X_PRE_LIBS"
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
++AC_CHECK_LIB(X11, XOpenDisplay, LIBS="$LIBS -lX11",
+ AC_MSG_ERROR(XOpenDisplay not found in -lX11))
+
+ dnl Checks for Xextension
+diff -ur bbmail-0.9.3.orig/src/bbmail.cpp bbmail-0.9.3/src/bbmail.cpp
+--- bbmail-0.9.3.orig/src/bbmail.cpp 2007-12-03 23:08:26.000000000 +0200
++++ bbmail-0.9.3/src/bbmail.cpp 2009-07-30 19:20:10.000000000 +0300
+@@ -19,6 +19,8 @@
+ // (See the included file COPYING / GPL-2.0)
+ //
+
++#include <cstdio>
++
+ #include "bbmail.h"
+ #include "config.h"
+ #include <string>
+diff -ur bbmail-0.9.3.orig/src/mailboxmenu.cpp bbmail-0.9.3/src/mailboxmenu.cpp
+--- bbmail-0.9.3.orig/src/mailboxmenu.cpp 2005-02-01 00:03:37.000000000 +0200
++++ bbmail-0.9.3/src/mailboxmenu.cpp 2009-07-30 19:20:39.000000000 +0300
+@@ -19,6 +19,9 @@
+ // (See the included file COPYING / GPL-2.0)
+ //
+ //
++
++#include <cstdio>
++
+ #include "mailboxmenu.h"
+
+ MailboxMenu::MailboxMenu(ToolWindow *toolwindow) :
+diff -ur bbmail-0.9.3.orig/src/main.cpp bbmail-0.9.3/src/main.cpp
+--- bbmail-0.9.3.orig/src/main.cpp 2006-01-20 23:28:08.000000000 +0200
++++ bbmail-0.9.3/src/main.cpp 2009-07-30 19:19:49.000000000 +0300
+@@ -19,6 +19,8 @@
+ // (See the included file COPYING / GPL-2.0)
+ //
+
++#include <cstdio>
++
+ #include "bbmail.h"
+ #include "main.h"
+ #include "config.h"
+diff -ur bbmail-0.9.3.orig/src/Makefile.am bbmail-0.9.3/src/Makefile.am
+--- bbmail-0.9.3.orig/src/Makefile.am 2005-09-06 23:57:42.000000000 +0300
++++ bbmail-0.9.3/src/Makefile.am 2009-07-30 19:24:39.000000000 +0300
+@@ -10,5 +10,4 @@
+ spoollist.cpp spoollist.h \
+ mailboxmenu.cpp mailboxmenu.h \
+ blackboxstyle.h
+-bbmail_LDADD = @X_LIBS@
+-
++bbmail_LDADD = @LIBS@
+diff -ur bbmail-0.9.3.orig/src/resource.cpp bbmail-0.9.3/src/resource.cpp
+--- bbmail-0.9.3.orig/src/resource.cpp 2007-08-28 19:47:19.000000000 +0300
++++ bbmail-0.9.3/src/resource.cpp 2009-07-30 19:20:00.000000000 +0300
+@@ -19,6 +19,8 @@
+ // (See the included file COPYING / GPL-2.0)
+ //
+
++#include <cstdio>
++
+ #include "bbmail.h"
+ #include "resource.h"
+ #include "blackboxstyle.h"
diff --git a/x11-misc/bbmail/metadata.xml b/x11-misc/bbmail/metadata.xml
new file mode 100644
index 000000000000..670d4c7bde18
--- /dev/null
+++ b/x11-misc/bbmail/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Mail notification for Blackbox.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bbtools</remote-id>
+ </upstream>
+</pkgmetadata>