summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-07-04 15:54:38 +0200
committerDavid Seifert <soap@gentoo.org>2020-07-04 15:54:38 +0200
commitc896cdb1dbde73a0a5a8bc939973d434c01a62da (patch)
treec20abbef7cb507abad2dfed057b85bc4203e7c98 /x11-misc/imwheel
parentx11-misc/imake: Pass CPP explicitly (diff)
downloadgentoo-c896cdb1dbde73a0a5a8bc939973d434c01a62da.tar.gz
gentoo-c896cdb1dbde73a0a5a8bc939973d434c01a62da.tar.bz2
gentoo-c896cdb1dbde73a0a5a8bc939973d434c01a62da.zip
x11-misc/imwheel: Call AM_PROG_AR
Closes: https://bugs.gentoo.org/726140 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc/imwheel')
-rw-r--r--x11-misc/imwheel/files/imwheel-1.0.0_pre13_p20100827-autotools.patch32
-rw-r--r--x11-misc/imwheel/imwheel-1.0.0_pre13_p20100827.ebuild18
2 files changed, 42 insertions, 8 deletions
diff --git a/x11-misc/imwheel/files/imwheel-1.0.0_pre13_p20100827-autotools.patch b/x11-misc/imwheel/files/imwheel-1.0.0_pre13_p20100827-autotools.patch
new file mode 100644
index 000000000000..e889f2a694ae
--- /dev/null
+++ b/x11-misc/imwheel/files/imwheel-1.0.0_pre13_p20100827-autotools.patch
@@ -0,0 +1,32 @@
+--- a/configure.in
++++ b/configure.in
+@@ -15,6 +15,7 @@
+ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
++AM_PROG_AR
+ AC_PROG_MAKE_SET
+ dnl AC_PREFIX_PROGRAM(bin/imwheel)
+ AM_CONFIG_HEADER(config.h)
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,7 +22,7 @@
+ find $(distdir) -name CVS -exec rm -rvf '{}' ';' ; \
+ done
+
+-ETCDIR=/etc/X11/imwheel
++ETCDIR=$(DESTDIR)/etc/X11/imwheel
+
+ install-exec-hook:
+ if SUID
+@@ -31,8 +31,8 @@
+ chmod u+s $$progname
+ endif
+ $(mkinstalldirs) $(ETCDIR)
+- -[ -f /etc/imwheelrc ] && mv /etc/imwheelrc $(ETCDIR)/imwheelrc || true
+- -[ -f /etc/X11/imwheelrc ] && mv /etc/X11/imwheelrc $(ETCDIR)/imwheelrc || true
++ -[ -f $(DESTDIR)/etc/imwheelrc ] && mv $(DESTDIR)/etc/imwheelrc $(ETCDIR)/imwheelrc || true
++ -[ -f $(DESTDIR)/etc/X11/imwheelrc ] && mv $(DESTDIR)/etc/X11/imwheelrc $(ETCDIR)/imwheelrc || true
+ -[ -f $(ETCDIR)/imwheelrc ] && install -m 644 imwheelrc $(ETCDIR)/imwheelrc.new || install -m 644 imwheelrc $(ETCDIR)/imwheelrc
+
+ extras: $(EXTRA_PROGRAMS)
diff --git a/x11-misc/imwheel/imwheel-1.0.0_pre13_p20100827.ebuild b/x11-misc/imwheel/imwheel-1.0.0_pre13_p20100827.ebuild
index 0898ec96384e..b2028583345f 100644
--- a/x11-misc/imwheel/imwheel-1.0.0_pre13_p20100827.ebuild
+++ b/x11-misc/imwheel/imwheel-1.0.0_pre13_p20100827.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
@@ -12,21 +12,23 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc x86"
-IUSE=""
-RDEPEND="x11-libs/libXtst
+RDEPEND="
+ x11-libs/libXtst
x11-libs/libX11
x11-libs/libXmu
x11-libs/libXt
x11-libs/libXext"
-
DEPEND="${RDEPEND}
- x11-base/xorg-proto
- >=sys-apps/sed-4"
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch # bug 726140
+)
src_prepare() {
default
- sed -i -e "s:/etc:${D}/etc:g" Makefile.am || die
+ mv configure.{in,ac} || die
eautoreconf
}