summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2023-05-19 23:14:48 -0700
committerSam James <sam@gentoo.org>2023-05-20 08:15:28 +0100
commitce089df530f15eb155e78e11c05f1ec22d1bb84b (patch)
treea77b8e47088330c40e90d6da0482af3cb3f7228a /x11-misc/ydotool
parentdev-python/markupsafe: Add GH remote-id (diff)
downloadgentoo-ce089df530f15eb155e78e11c05f1ec22d1bb84b.tar.gz
gentoo-ce089df530f15eb155e78e11c05f1ec22d1bb84b.tar.bz2
gentoo-ce089df530f15eb155e78e11c05f1ec22d1bb84b.zip
x11-misc/ydotool: new package, add 1.0.4
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Closes: https://github.com/gentoo/gentoo/pull/31102 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/ydotool')
-rw-r--r--x11-misc/ydotool/Manifest1
-rw-r--r--x11-misc/ydotool/metadata.xml22
-rw-r--r--x11-misc/ydotool/ydotool-1.0.4.ebuild21
3 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/ydotool/Manifest b/x11-misc/ydotool/Manifest
new file mode 100644
index 000000000000..9fe77b15836b
--- /dev/null
+++ b/x11-misc/ydotool/Manifest
@@ -0,0 +1 @@
+DIST ydotool-1.0.4.tar.gz 29364 BLAKE2B d021d0bc6cea3118cb91bd1e0cf0eab6b808925902c29274a417f16b0727998904085ca725411371284f222d7a043b9f3460725a07a911d40d0bd477d4fe9fcb SHA512 bbf66d752aa1dce9173c930e3a71bc277b330763b1aa0e38f9fec1976c282c64330251ba5abe222a991f4bcafbabf1312a940eb4b40a34bf99f628c2a41bc4a2
diff --git a/x11-misc/ydotool/metadata.xml b/x11-misc/ydotool/metadata.xml
new file mode 100644
index 000000000000..6144f457ca39
--- /dev/null
+++ b/x11-misc/ydotool/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zoltan@sinustrom.info</email>
+ <name>Zoltan Puskas</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Generic Linux command-line automation tool (no X!) ou can use it on
+ anything as long as it accepts keyboard/mouse/whatever input. For
+ example, X11, text console, "RetroArch OS", fbdev apps
+ (fbterm/mplayer/SDL1/LittleVGL/Qt Embedded), etc.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ReimuNotMoe/ydotool</remote-id>
+ <bugs-to>https://github.com/ReimuNotMoe/ydotool/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/ydotool/ydotool-1.0.4.ebuild b/x11-misc/ydotool/ydotool-1.0.4.ebuild
new file mode 100644
index 000000000000..59f495186068
--- /dev/null
+++ b/x11-misc/ydotool/ydotool-1.0.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Generic command-line automation tool (no X!)"
+HOMEPAGE="https://github.com/ReimuNotMoe/ydotool"
+SRC_URI="https://github.com/ReimuNotMoe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-text/scdoc"
+
+src_install() {
+ cmake_src_install
+ newinitd Daemon/ydotool.service-openrc.in ydotoold
+}