summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <ya@sysdump.net>2018-03-20 22:47:14 -0700
committerMichał Górny <mgorny@gentoo.org>2018-03-25 22:12:57 +0200
commitd211ade1305d333328a36e63e76f5d3c6e4890f8 (patch)
tree259fa1837d398612533abc0ac44a515636bd3379 /x11-misc
parentmedia-libs/waffle: keyworded 1.5.2 for ppc, bug #651152 (diff)
downloadgentoo-d211ade1305d333328a36e63e76f5d3c6e4890f8.tar.gz
gentoo-d211ade1305d333328a36e63e76f5d3c6e4890f8.tar.bz2
gentoo-d211ade1305d333328a36e63e76f5d3c6e4890f8.zip
x11-misc/xwallpaper: new package, modern wallpaper tool
Closes: https://bugs.gentoo.org/651054 Closes: https://github.com/gentoo/gentoo/pull/7529 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xwallpaper/Manifest1
-rw-r--r--x11-misc/xwallpaper/metadata.xml22
-rw-r--r--x11-misc/xwallpaper/xwallpaper-0.3.0.ebuild48
-rw-r--r--x11-misc/xwallpaper/xwallpaper-9999.ebuild48
4 files changed, 119 insertions, 0 deletions
diff --git a/x11-misc/xwallpaper/Manifest b/x11-misc/xwallpaper/Manifest
new file mode 100644
index 000000000000..8cb099943239
--- /dev/null
+++ b/x11-misc/xwallpaper/Manifest
@@ -0,0 +1 @@
+DIST xwallpaper-0.3.0.tar.gz 104300 BLAKE2B 23ec3b4ccbaf910c9ba4afbd1d9237223654a85c90b0a147141b017a9b3917316f745e1dd70a89e385110d380d5bbba8ee7c2d1ed4188d87a98ba0e94c5a7b6c SHA512 c73583fdbd573329951178d7db36fb1ae18a4294207de85dfb93e367be0ed103e8de7e2dd8ec61a0a23541457c930e8b0e5eb12dd5024808de3e02ddefb6b4a3
diff --git a/x11-misc/xwallpaper/metadata.xml b/x11-misc/xwallpaper/metadata.xml
new file mode 100644
index 000000000000..36a2d7518765
--- /dev/null
+++ b/x11-misc/xwallpaper/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ya@sysdump.net</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ The xwallpaper utility allows you to set image files as your X wallpaper.
+ JPEG, PNG, and XPM file formats are supported, all of them being configurable and therefore no fixed dependencies.
+ The wallpaper is also advertised to programs which support semi-transparent backgrounds.
+ The last but not least focus of this project is to write a secure wallpaper utility,
+ supporting very tight sandboxing mechanisms.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">stoeckmann/xwallpaper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/xwallpaper/xwallpaper-0.3.0.ebuild b/x11-misc/xwallpaper/xwallpaper-0.3.0.ebuild
new file mode 100644
index 000000000000..45080788129f
--- /dev/null
+++ b/x11-misc/xwallpaper/xwallpaper-0.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+ SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="jpeg png seccomp xpm"
+
+DEPEND="
+ x11-libs/pixman
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ jpeg? ( virtual/jpeg:0= )
+ png? ( media-libs/libpng:0= )
+ seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+ xpm? ( x11-libs/libXpm )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+src_configure() {
+ local myconf=(
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with seccomp)
+ $(use_with xpm)
+ --with-randr
+ --with-zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ )
+ econf "${myconf[@]}"
+}
diff --git a/x11-misc/xwallpaper/xwallpaper-9999.ebuild b/x11-misc/xwallpaper/xwallpaper-9999.ebuild
new file mode 100644
index 000000000000..45080788129f
--- /dev/null
+++ b/x11-misc/xwallpaper/xwallpaper-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+ SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="jpeg png seccomp xpm"
+
+DEPEND="
+ x11-libs/pixman
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ jpeg? ( virtual/jpeg:0= )
+ png? ( media-libs/libpng:0= )
+ seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+ xpm? ( x11-libs/libXpm )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+src_configure() {
+ local myconf=(
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with seccomp)
+ $(use_with xpm)
+ --with-randr
+ --with-zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ )
+ econf "${myconf[@]}"
+}