summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-18 21:59:35 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-18 21:59:57 -0600
commit186b2f244bb91042a5e6a5d69e333f4cade91ba9 (patch)
treeb36c6f36dc293ad0f8026a34715c2d4de0826083 /x11-plugins/vicious/vicious-2.3.1.ebuild
parentx11-plugins/enigmail: Bump to version 1.9.9 (diff)
downloadgentoo-186b2f244bb91042a5e6a5d69e333f4cade91ba9.tar.gz
gentoo-186b2f244bb91042a5e6a5d69e333f4cade91ba9.tar.bz2
gentoo-186b2f244bb91042a5e6a5d69e333f4cade91ba9.zip
x11-plugins/vicious: 2.3.1 bup
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'x11-plugins/vicious/vicious-2.3.1.ebuild')
-rw-r--r--x11-plugins/vicious/vicious-2.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-plugins/vicious/vicious-2.3.1.ebuild b/x11-plugins/vicious/vicious-2.3.1.ebuild
new file mode 100644
index 000000000000..601ea74cde5b
--- /dev/null
+++ b/x11-plugins/vicious/vicious-2.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Modular widget library for x11-wm/awesome"
+HOMEPAGE="https://github.com/Mic92/vicious"
+SRC_URI="https://github.com/Mic92/vicious/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="contrib"
+
+DEPEND=""
+RDEPEND="x11-wm/awesome"
+
+src_install() {
+ insinto /usr/share/awesome/lib/vicious
+ doins -r widgets helpers.lua init.lua
+ dodoc Changes.md README.md TODO
+
+ if use contrib; then
+ insinto /usr/share/awesome/lib/vicious/contrib
+ doins contrib/*.lua
+ newdoc contrib/README.md README.contrib
+ fi
+}