summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-01-01 16:47:55 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-01-01 16:48:50 +0100
commitfdd5a72b90396ae4a152df30a9f67437def59a74 (patch)
treee0d8261a68ab9a4e4e341c57f83387b140806f73 /x11-plugins
parentsys-fs/mdadm: Bump to version 4.2. Removed old (diff)
downloadgentoo-fdd5a72b90396ae4a152df30a9f67437def59a74.tar.gz
gentoo-fdd5a72b90396ae4a152df30a9f67437def59a74.tar.bz2
gentoo-fdd5a72b90396ae4a152df30a9f67437def59a74.zip
x11-plugins/gkrellshoot: respect LDFLAGS
Signed-off-by: Florian Schmaus <flow@gentoo.org> Closes: https://bugs.gentoo.org/338867
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellshoot/files/makefile-respect-flags.patch26
-rw-r--r--x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r3.ebuild (renamed from x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r2.ebuild)6
2 files changed, 31 insertions, 1 deletions
diff --git a/x11-plugins/gkrellshoot/files/makefile-respect-flags.patch b/x11-plugins/gkrellshoot/files/makefile-respect-flags.patch
new file mode 100644
index 000000000000..8de89009dbbc
--- /dev/null
+++ b/x11-plugins/gkrellshoot/files/makefile-respect-flags.patch
@@ -0,0 +1,26 @@
+--- a/Makefile 2006-12-09 04:24:36.000000000 +0100
++++ b/Makefile 2013-03-16 13:50:00.147834790 +0100
+@@ -1,16 +1,20 @@
+ GTK_INCLUDE = `pkg-config gtk+-2.0 --cflags`
+ GTK_LIB = `pkg-config gtk+-2.0 --libs`
+
+-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE)
++FLAGS = -fPIC $(GTK_INCLUDE)
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+
+-CC = gcc $(CFLAGS) $(FLAGS)
+
+ OBJS = gkrellshoot.o
+
++all: gkrellshoot.so
++
++%.o: %.c
++ $(CC) $(CFLAGS) $(LDFLAGS) $(FLAGS) -c -o $@ $<
++
+ gkrellshoot.so: $(OBJS)
+- $(CC) $(OBJS) -o gkrellshoot.so $(LFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(FLAGS) $(OBJS) -o gkrellshoot.so $(LFLAGS) $(LIBS)
+
+ clean:
+ rm -f *.o core *.so* *.bak *~
diff --git a/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r2.ebuild b/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r3.ebuild
index ad424be2249b..028ef92f7eb6 100644
--- a/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r2.ebuild
+++ b/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,3 +20,7 @@ RDEPEND="
virtual/imagemagick-tools"
S=${WORKDIR}/${P/s/S}
+
+PATCHES=(
+ "${FILESDIR}"/makefile-respect-flags.patch
+)