summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-03-19 17:43:23 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-06 13:48:01 -0400
commit339d636db52c77bb4d00d5c724bc829fc9b9a70c (patch)
tree6d74e00601e875e0a008431c723b8a932f4c67a1 /x11-themes/mate-icon-theme/mate-icon-theme-1.24.0.ebuild
parentdev-libs/libmateweather: Fix LICENSE (diff)
downloadgentoo-339d636db52c77bb4d00d5c724bc829fc9b9a70c.tar.gz
gentoo-339d636db52c77bb4d00d5c724bc829fc9b9a70c.tar.bz2
gentoo-339d636db52c77bb4d00d5c724bc829fc9b9a70c.zip
x11-themes/mate-icon-theme: Bump to 1.24.0
Package-Manager: Portage-2.3.82, Repoman-2.3.18 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'x11-themes/mate-icon-theme/mate-icon-theme-1.24.0.ebuild')
-rw-r--r--x11-themes/mate-icon-theme/mate-icon-theme-1.24.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-themes/mate-icon-theme/mate-icon-theme-1.24.0.ebuild b/x11-themes/mate-icon-theme/mate-icon-theme-1.24.0.ebuild
new file mode 100644
index 000000000000..7643892dda78
--- /dev/null
+++ b/x11-themes/mate-icon-theme/mate-icon-theme-1.24.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE default icon themes"
+LICENSE="CC-BY-SA-3.0 CC-PD GPL-1+"
+SLOT="0"
+
+COMMON_DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7:0
+ >=sys-devel/gettext-0.19.8:*
+ virtual/pkgconfig:*"
+
+RESTRICT="binchecks strip"
+
+src_configure() {
+ mate_src_configure --enable-icon-mapping
+}