summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-04-26 12:29:33 +0200
committerPacho Ramos <pacho@gentoo.org>2022-04-26 12:29:33 +0200
commit236f0d768af32b552c6df2a2b596de7d0d6dce50 (patch)
tree1a8d3048f00f0642e81840d43bb5a7c77175cbf3 /x11-themes
parentnet-misc/you-get: add 0.4.1602 (diff)
downloadgentoo-236f0d768af32b552c6df2a2b596de7d0d6dce50.tar.gz
gentoo-236f0d768af32b552c6df2a2b596de7d0d6dce50.tar.bz2
gentoo-236f0d768af32b552c6df2a2b596de7d0d6dce50.zip
x11-themes/QGnomePlatform: Fix window id for xdg-desktop-portal file chooser
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.8.4-r1.ebuild39
-rw-r--r--x11-themes/QGnomePlatform/files/QGnomePlatform-0.8.4-xdg-desktop-portal-id.patch11
2 files changed, 50 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.8.4-r1.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..a39961a0d0df
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.8.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtdbus:5=
+ >=dev-qt/qtwidgets-5.15.2:5=
+ dev-qt/qtwayland:5=
+ dev-qt/qtx11extras:5=
+ gnome-base/gsettings-desktop-schemas
+ sys-apps/xdg-desktop-portal
+ x11-libs/gtk+:3[X]
+ >=x11-themes/adwaita-qt-1.4.1
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ # https://github.com/FedoraQt/QGnomePlatform/issues/101
+ "${FILESDIR}/${P}-xdg-desktop-portal-id.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT6=false
+ )
+ cmake_src_configure
+}
diff --git a/x11-themes/QGnomePlatform/files/QGnomePlatform-0.8.4-xdg-desktop-portal-id.patch b/x11-themes/QGnomePlatform/files/QGnomePlatform-0.8.4-xdg-desktop-portal-id.patch
new file mode 100644
index 000000000000..292088bd1f84
--- /dev/null
+++ b/x11-themes/QGnomePlatform/files/QGnomePlatform-0.8.4-xdg-desktop-portal-id.patch
@@ -0,0 +1,11 @@
+--- a/src/theme/qxdgdesktopportalfiledialog.cpp~ 2022-01-11 10:46:15.000000000 +0100
++++ b/src/theme/qxdgdesktopportalfiledialog.cpp 2022-04-26 12:16:07.504955234 +0200
+@@ -165,7 +165,7 @@
+ QLatin1String("/org/freedesktop/portal/desktop"),
+ QLatin1String("org.freedesktop.portal.FileChooser"),
+ d->saveFile ? QLatin1String("SaveFile") : QLatin1String("OpenFile"));
+- QString parentWindowId = QLatin1String("x11:") + QString::number(d->winId);
++ QString parentWindowId = QLatin1String("x11:") + QString::number(d->winId, 16);
+
+ QVariantMap options;
+ if (!d->acceptLabel.isEmpty())