summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-12 16:19:19 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-09-25 16:14:07 +0200
commit6b71d84ebc77686ae088f6877c8a993e7341622d (patch)
treef9f69e31a2afb2257ed3bc4505ffaa189d618fc3 /x11-themes
parentwww-apps/radarr-bin: drop 5.10.4.9218 (diff)
downloadgentoo-6b71d84ebc77686ae088f6877c8a993e7341622d.tar.gz
gentoo-6b71d84ebc77686ae088f6877c8a993e7341622d.tar.bz2
gentoo-6b71d84ebc77686ae088f6877c8a993e7341622d.zip
x11-themes/gnustep-neos-theme: bump EAPI & more
- HTTPS homepage - remove redirection from SRC_URI - move S - remove empty IUSE Signed-off-by: Filip Kobierski <fkobi@pm.me> Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnustep-neos-theme/gnustep-neos-theme-0.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-themes/gnustep-neos-theme/gnustep-neos-theme-0.1-r2.ebuild b/x11-themes/gnustep-neos-theme/gnustep-neos-theme-0.1-r2.ebuild
new file mode 100644
index 000000000000..7f7430ae03d1
--- /dev/null
+++ b/x11-themes/gnustep-neos-theme/gnustep-neos-theme-0.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnustep-2 vcs-clean
+
+DESCRIPTION="GNUstep theme closely following the original NeXT look and feel"
+HOMEPAGE="https://gap.nongnu.org/themes/index.html"
+SRC_URI="https://download.savannah.gnu.org/releases/gap/Neos-${PV}.theme.tar.gz"
+S=${WORKDIR}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ default
+ ecvs_clean
+}
+
+src_compile() { :; }
+
+src_install() {
+ egnustep_env
+
+ #install themes
+ insinto ${GNUSTEP_SYSTEM_LIBRARY}/Themes
+ doins -r "${S}"/*theme
+}
+
+pkg_postinst() {
+ elog "Use gnustep-apps/systempreferences to switch theme"
+}