summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2022-06-03 01:27:33 +1000
committerSam James <sam@gentoo.org>2022-06-04 03:19:19 +0100
commitdf84fc47751dfa68cf08247748ba9e71a194dc09 (patch)
tree93ed9d7b6faeeec8b4e6b9d64128df2c7a3e6550 /x11-themes
parentx11-wm/fvwm3: new package, add 1.0.4, 9999 (diff)
downloadgentoo-df84fc47751dfa68cf08247748ba9e71a194dc09.tar.gz
gentoo-df84fc47751dfa68cf08247748ba9e71a194dc09.tar.bz2
gentoo-df84fc47751dfa68cf08247748ba9e71a194dc09.zip
x11-themes/fvwm-crystal: add 3.7.5
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/fvwm-crystal/Manifest1
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.7.5.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/x11-themes/fvwm-crystal/Manifest b/x11-themes/fvwm-crystal/Manifest
index 8f13e6ea878e..a66e97caa728 100644
--- a/x11-themes/fvwm-crystal/Manifest
+++ b/x11-themes/fvwm-crystal/Manifest
@@ -1,2 +1,3 @@
DIST fvwm-crystal-3.6.5.tar.gz 5899049 BLAKE2B addd82dbbab9b457a94715a969a27ff6ef2be07cddd33a379dc4d5348c9565d3a19943828b068ec5ef5f6d032f51b77a1990316ee7b3e16e5dc98ddf32f98c7d SHA512 45cd99b83342e5e5f0de89edc92dbba3311efc7ef431d509490e3fd5b49420e94d1cef55865f45e731fd4c13172c6e2d26fbd10107cdb4a4f525379e17b94e6d
DIST fvwm-crystal-3.7.1.tar.gz 5936306 BLAKE2B 3a47ddab10365faf13c4b9de8ac172b2f91073addd7799315a47901c10b28b6b16c89ccb9c4a313285cd1e9b40d6ecd8b563e8764bb063d249ceb54804d63ec7 SHA512 0e61bd190ab0b9f4c51b65e9bbeb3689c38127769166f90fc2eff655c68b11c60e67ef35417ed7e97d06bb549d2a87ba6785fc6530a5269d19c1243d3cbe27ed
+DIST fvwm-crystal-3.7.5.tar.gz 5962351 BLAKE2B b5a7458c5bc97846ba48e18168da05d0cda4f26b2f0252abcfd12953de4ac80b34a521759152d559fef59ab53e5f252434d1f1840a779271fc9fffd7ec8632b0 SHA512 333eeeabf1b7b88e1ce7ba5e018a013471db215214b5d9bd86d0f0e107d7443f89bc409e23f3ef4a61c9ced63b862614507cb5ae74063f14d9e0d8b1eb97186b
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.7.5.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.7.5.ebuild
new file mode 100644
index 000000000000..67e6e4b1901e
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.7.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit readme.gentoo-r1 python-single-r1 optfeature
+
+DESCRIPTION="Configurable FVWM theme with transparency and freedesktop compatible menu"
+HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fvwm-crystal/fvwm-crystal.git"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+RDEPEND="${PYTHON_DEPS}
+ acct-group/fvwm-crystal
+ || ( >=x11-wm/fvwm3-1.0.4[go] >=x11-wm/fvwm-2.6.9[png] )
+ virtual/imagemagick-tools
+ || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
+ || ( x11-misc/hsetroot media-gfx/feh )
+ sys-apps/sed
+ sys-devel/bc
+ virtual/awk
+ x11-apps/xwd
+ media-sound/alsa-utils"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="After a first time installation, execute the following commands:
+ $ cp -r "${EROOT}"/usr/share/doc/"${PF}"/addons/Xresources ~/.Xresources
+ $ cp -r "${EROOT}"/usr/share/doc/"${PF}"/addons/Xsession ~/.xinitrc
+You can edit these files at your convenience.
+
+Many applications can extend functionality of fvwm-crystal.
+They are listed in "${EROOT}"/usr/share/doc/"${PF}"/INSTALL.*
+
+To be able to use the exit menu, each user using ${PN}
+must be in the group fvwm-crystal.
+You can do that as root with:
+ $ useradd -G fvwm-crystal <user_name>
+and log out and in again.
+"
+
+src_install() {
+ emake DESTDIR="${ED}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
+ # GNU License is globally in the portage tree
+ rm -vf "${ED}/usr/share/doc/${PF}"/LICENSE
+
+ python_doscript "${ED}/usr/bin/${PN}".{apps,wallpaper}
+ python_scriptinto "/usr/share/${PN}"/fvwm/scripts/FvwmMPD
+ python_doscript "${ED}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ optfeature "localized XDG user directories support" "x11-misc/xdg-user-dirs"
+ optfeature "hibernate/resume support" "sys-apps/systemd"
+ optfeature "professional sound server" "media-sound/jack-audio-connection-kit"
+}