summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-18 16:44:32 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-18 16:44:32 +0200
commita7487d6657d5da05f029d6734ebe024d5eb34af7 (patch)
tree947b30548e3f2b78e9f8507b4809c0df998bd0a3 /x11-wm
parentwww-client/chromium: fix build on arm64 without crc extension (diff)
downloadgentoo-a7487d6657d5da05f029d6734ebe024d5eb34af7.tar.gz
gentoo-a7487d6657d5da05f029d6734ebe024d5eb34af7.tar.bz2
gentoo-a7487d6657d5da05f029d6734ebe024d5eb34af7.zip
x11-wm/fvwm3: [QA] pass AR to make
Closes: https://bugs.gentoo.org/849761 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fvwm3/fvwm3-1.0.4-r2.ebuild4
-rw-r--r--x11-wm/fvwm3/fvwm3-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/x11-wm/fvwm3/fvwm3-1.0.4-r2.ebuild b/x11-wm/fvwm3/fvwm3-1.0.4-r2.ebuild
index 0a0e5ddfb57a..afd245eccd27 100644
--- a/x11-wm/fvwm3/fvwm3-1.0.4-r2.ebuild
+++ b/x11-wm/fvwm3/fvwm3-1.0.4-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
GO_OPTIONAL=1
-inherit autotools desktop flag-o-matic go-module python-single-r1
+inherit autotools desktop flag-o-matic go-module python-single-r1 toolchain-funcs
DESCRIPTION="A multiple large virtual desktop window manager derived from fvwm"
HOMEPAGE="http://www.fvwm.org/"
@@ -138,7 +138,7 @@ src_configure() {
}
src_compile() {
- PREFIX="/usr" emake
+ PREFIX="${EPREFIX}/usr" emake AR="$(tc-getAR)"
if [[ ${PV} == *9999 ]]; then
use doc && emake -C doc html
fi
diff --git a/x11-wm/fvwm3/fvwm3-9999.ebuild b/x11-wm/fvwm3/fvwm3-9999.ebuild
index 224ee2abd20a..65fdb8f91459 100644
--- a/x11-wm/fvwm3/fvwm3-9999.ebuild
+++ b/x11-wm/fvwm3/fvwm3-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
GO_OPTIONAL=1
-inherit autotools desktop flag-o-matic go-module python-single-r1
+inherit autotools desktop flag-o-matic go-module python-single-r1 toolchain-funcs
DESCRIPTION="A multiple large virtual desktop window manager derived from fvwm"
HOMEPAGE="http://www.fvwm.org/"
@@ -138,7 +138,7 @@ src_configure() {
}
src_compile() {
- PREFIX="/usr" emake
+ PREFIX="${EPREFIX}/usr" emake AR="$(tc-getAR)"
if [[ ${PV} == *9999 ]]; then
use doc && emake -C doc html
fi