summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-08 13:58:57 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-08 14:01:44 +0100
commitc53ec819fc0be9a85ad581f6a32191659dd1ce4c (patch)
tree0ea6010fc020d75a96a582b48ba9a9912ab47028 /xfce-base
parentdev-dotnet/dotnet-sdk-bin: Stabilize 8.0.101-r3 amd64, #926442 (diff)
downloadgentoo-c53ec819fc0be9a85ad581f6a32191659dd1ce4c.tar.gz
gentoo-c53ec819fc0be9a85ad581f6a32191659dd1ce4c.tar.bz2
gentoo-c53ec819fc0be9a85ad581f6a32191659dd1ce4c.zip
xfce-base/libxfce4ui: Bump to 4.18.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.18.6.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 43d06dc1920d..d07b1bf467b8 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4ui-4.18.5.tar.bz2 906155 BLAKE2B 2fb977ecbb6c02c485ed2575d189140c5cdce4090529aabbd6a220986cb53241aecfa3a1d1ed79ae873a53d14fa6af80c0732050c6d6aace949e47ba2d71bf8f SHA512 b8b64bf2b71bc327a94c9292b6e1ad5647c6f91b3a806faad894d9973955ec3b05f14a28c0486604c518f7cef1f676337c1405f7d04a8b7b8698f1725346c0f5
+DIST libxfce4ui-4.18.6.tar.bz2 906477 BLAKE2B b9b1a6a3a82760147cdcf9cd462c58044f640bb0c6eaa96f1f56247d6d01ce3ca97d47f6ffa03206452d0501250d6c72fd0c018870ed2c679e9226f44e618ce4 SHA512 1c704dd26793a304fef98c48bc3ca860248e746e9e5c39f22e984439e1a20209763e80e40e6bffcf8f0d773b323b825ebd5da4d88352582e56dfeb7c9b2ca47c
DIST libxfce4ui-4.19.5.tar.bz2 1185047 BLAKE2B 3c05d0b4d7756699d0591154765f66ffae6e528d1e58963f182921e7070639e708fbbe924bd54d9cb76fca7423b56fe6938c669a8c6f2268831c97aa22158403 SHA512 c8db19e04e3c529c2374238444cc77ef9d3454de4734fff269c1e60c9d1011c0c66cadb926561c7f122485707c75d88835c7dbb4af674c1ad0ff772af50a38d5
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.18.6.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.18.6.ebuild
new file mode 100644
index 000000000000..e3eda5880a06
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.18.6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/libxfce4ui/start
+ https://gitlab.xfce.org/xfce/libxfce4ui/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="glade +introspection startup-notification system-info vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3[introspection?,X]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.17.2:=[introspection?,vala?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+ startup-notification? ( x11-libs/startup-notification )
+ system-info? (
+ dev-libs/libgudev
+ gnome-base/libgtop
+ >=media-libs/libepoxy-1.2
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}