summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/yangcli-pro/Manifest1
-rw-r--r--net-misc/yangcli-pro/metadata.xml8
-rw-r--r--net-misc/yangcli-pro/yangcli-pro-16.10_p8.ebuild38
3 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/yangcli-pro/Manifest b/net-misc/yangcli-pro/Manifest
new file mode 100644
index 000000000000..6583a0cf9812
--- /dev/null
+++ b/net-misc/yangcli-pro/Manifest
@@ -0,0 +1 @@
+DIST yangcli-pro-16.10-8.deb8.amd64.deb 1406108 SHA256 4c69d5fd9c99272a8bb1074cdf3bc9de616866bb078546c214df86eefaa8bc10 SHA512 23db68a22d83a95638f1c155126118290fba38fd1bca524d29c75f227a14b15f20982c47b598c235b4e78e905090c17b242a27d59350cbcd9b4179da070d74c6 WHIRLPOOL a941936193e07f450a866692c5c153f9d67e309728fdf4a47bb27f2ce0a67d5069facb286e2af99700ff5920861aa3275a2b8ccbbf9b812b3e424ea41317b037
diff --git a/net-misc/yangcli-pro/metadata.xml b/net-misc/yangcli-pro/metadata.xml
new file mode 100644
index 000000000000..5087760546f6
--- /dev/null
+++ b/net-misc/yangcli-pro/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/yangcli-pro/yangcli-pro-16.10_p8.ebuild b/net-misc/yangcli-pro/yangcli-pro-16.10_p8.ebuild
new file mode 100644
index 000000000000..158e6c6d4b01
--- /dev/null
+++ b/net-misc/yangcli-pro/yangcli-pro-16.10_p8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit unpacker
+
+RESTRICT="bindist mirror strip"
+MY_PV=${PV/_p/-}
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}
+
+DESCRIPTION="Network manager client that lets you test and manage NETCONF servers"
+HOMEPAGE="https://www.yumaworks.com/yangcli-pro/"
+SRC_URI="amd64? ( https://www.yumaworks.com/pub/${PN}/${MY_PV}/deb8/${MY_P}.deb8.amd64.deb )"
+
+LICENSE="yangcli-pro"
+SLOT="0"
+KEYWORDS="~amd64 -*"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:5/5[tinfo]"
+
+src_install() {
+ dodoc usr/share/doc/yangcli-pro/changelog.gz
+ dodoc usr/share/doc/yumapro/*.pdf
+ dodoc usr/share/doc/yumapro/README
+ dobin usr/bin/yangcli-pro
+ dolib usr/lib/libyumapro_{ncx,mgr,ycli}.so{,.16.10}
+ doman usr/share/man/man1/yangcli-pro.1.gz
+ local my_module
+ for my_module in ietf/{RFC,DRAFT} netconfcentral yumaworks ; do
+ insinto /usr/share/yumapro/modules/${my_module}
+ doins usr/share/yumapro/modules/${my_module}/*.yang
+ done
+ insinto /etc/yumapro
+ doins etc/yumapro/yangcli-pro-sample.conf
+}