summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-misc/c++robots/c++robots-0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-misc/c++robots/c++robots-0-r1.ebuild b/games-misc/c++robots/c++robots-0-r1.ebuild
new file mode 100644
index 000000000000..d92a5a7d1aab
--- /dev/null
+++ b/games-misc/c++robots/c++robots-0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="ongoing 'King of the Hill' (KotH) tournament"
+HOMEPAGE="http://www.gamerz.net/c++robots/"
+SRC_URI="http://www.gamerz.net/c++robots/c++robots.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="static"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}/proper-coding.patch"
+)
+
+src_compile() {
+ local myldflags="${LDFLAGS}"
+ use static && myldflags="${myldflags} -static"
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${myldflags}"
+}
+
+src_install() {
+ dobin combat cylon target tracker
+ dodoc README
+}