summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/ocaml/ocaml-4.05.0-r7.ebuild (renamed from dev-lang/ocaml/ocaml-4.05.0-r5.ebuild)10
-rw-r--r--dev-lang/ocaml/ocaml-4.05.0-r8.ebuild (renamed from dev-lang/ocaml/ocaml-4.05.0-r6.ebuild)12
-rw-r--r--dev-lang/ocaml/ocaml-4.09.0-r2.ebuild (renamed from dev-lang/ocaml/ocaml-4.09.0-r1.ebuild)11
-rw-r--r--dev-lang/ocaml/ocaml-4.10.2-r2.ebuild (renamed from dev-lang/ocaml/ocaml-4.10.2-r1.ebuild)10
-rw-r--r--dev-lang/ocaml/ocaml-4.11.2-r2.ebuild (renamed from dev-lang/ocaml/ocaml-4.11.2-r1.ebuild)15
-rw-r--r--dev-lang/ocaml/ocaml-4.12.0-r2.ebuild (renamed from dev-lang/ocaml/ocaml-4.12.0-r1.ebuild)14
6 files changed, 51 insertions, 21 deletions
diff --git a/dev-lang/ocaml/ocaml-4.05.0-r5.ebuild b/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild
index 36adb282101c..ebd032a4fd80 100644
--- a/dev-lang/ocaml/ocaml-4.05.0-r5.ebuild
+++ b/dev-lang/ocaml/ocaml-4.05.0-r7.ebuild
@@ -50,6 +50,9 @@ pkg_setup() {
src_prepare() {
EPATCH_SUFFIX="patch" eapply "${WORKDIR}/patches"
+
+ cp "${FILESDIR}"/ocaml.conf "${T}" || die
+
default
}
@@ -133,10 +136,13 @@ src_install() {
dodoc Changes README.adoc
# Create envd entry for latex input files
if use latex ; then
- echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}/99ocamldoc"
+ echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}"/99ocamldoc || die
doenvd "${T}/99ocamldoc"
fi
+
+ sed -i -e "s:lib:$(get_libdir):" "${T}"/ocaml.conf || die
+
# Install ocaml-rebuild portage set
insinto /usr/share/portage/config/sets
- doins "${FILESDIR}/ocaml.conf"
+ doins "${T}"/ocaml.conf
}
diff --git a/dev-lang/ocaml/ocaml-4.05.0-r6.ebuild b/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild
index ae3120cad728..11c811147b40 100644
--- a/dev-lang/ocaml/ocaml-4.05.0-r6.ebuild
+++ b/dev-lang/ocaml/ocaml-4.05.0-r8.ebuild
@@ -51,6 +51,9 @@ pkg_setup() {
src_prepare() {
EPATCH_SUFFIX="patch" eapply "${WORKDIR}/patches"
+
+ cp "${FILESDIR}"/ocaml.conf "${T}" || die
+
default
}
@@ -134,10 +137,13 @@ src_install() {
dodoc Changes README.adoc
# Create envd entry for latex input files
if use latex ; then
- echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}/99ocamldoc"
- doenvd "${T}/99ocamldoc"
+ echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}"/99ocamldoc || die
+ doenvd "${T}"/99ocamldoc
fi
+
+ sed -i -e "s:lib:$(get_libdir):" "${T}"/ocaml.conf || die
+
# Install ocaml-rebuild portage set
insinto /usr/share/portage/config/sets
- doins "${FILESDIR}/ocaml.conf"
+ doins "${T}"/ocaml.conf
}
diff --git a/dev-lang/ocaml/ocaml-4.09.0-r1.ebuild b/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild
index 14dc7a908b0e..23d27276013c 100644
--- a/dev-lang/ocaml/ocaml-4.09.0-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-4.09.0-r2.ebuild
@@ -26,6 +26,8 @@ PATCHES=("${FILESDIR}"/${PN}-4.09.0-gcc-10.patch)
src_prepare() {
default
+ cp "${FILESDIR}"/ocaml.conf "${T}" || die
+
# OCaml generates textrels on 32-bit arches
# We can't do anything about it, but disabling it means that tests
# for OCaml-based packages won't fail on unexpected output
@@ -80,10 +82,13 @@ src_install() {
dodoc Changes README.adoc
# Create envd entry for latex input files
if use latex ; then
- echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}/99ocamldoc"
- doenvd "${T}/99ocamldoc"
+ echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}"/99ocamldoc || die
+ doenvd "${T}"/99ocamldoc
fi
+
+ sed -i -e "s:lib:$(get_libdir):" "${T}"/ocaml.conf || die
+
# Install ocaml-rebuild portage set
insinto /usr/share/portage/config/sets
- doins "${FILESDIR}/ocaml.conf"
+ doins "${T}"/ocaml.conf
}
diff --git a/dev-lang/ocaml/ocaml-4.10.2-r1.ebuild b/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild
index e1ca18aa9617..7203dec65d67 100644
--- a/dev-lang/ocaml/ocaml-4.10.2-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-4.10.2-r2.ebuild
@@ -24,6 +24,8 @@ PDEPEND="emacs? ( app-emacs/ocaml-mode )
src_prepare() {
default
+ cp "${FILESDIR}"/ocaml.conf "${T}" || die
+
# OCaml generates textrels on 32-bit arches
# We can't do anything about it, but disabling it means that tests
# for OCaml-based packages won't fail on unexpected output
@@ -80,11 +82,13 @@ src_install() {
# Create envd entry for latex input files
if use latex ; then
- echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}/99ocamldoc"
- doenvd "${T}/99ocamldoc"
+ echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}/99ocamldoc" || die
+ doenvd "${T}"/99ocamldoc
fi
+ sed -i -e "s:lib:$(get_libdir):" "${T}"/ocaml.conf || die
+
# Install ocaml-rebuild portage set
insinto /usr/share/portage/config/sets
- doins "${FILESDIR}/ocaml.conf"
+ doins "${T}"/ocaml.conf
}
diff --git a/dev-lang/ocaml/ocaml-4.11.2-r1.ebuild b/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild
index f1ad43dbf997..3ef5a4d10154 100644
--- a/dev-lang/ocaml/ocaml-4.11.2-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-4.11.2-r2.ebuild
@@ -24,13 +24,15 @@ PDEPEND="emacs? ( app-emacs/ocaml-mode )
src_prepare() {
default
+ cp "${FILESDIR}"/ocaml.conf "${T}" || die
+
# OCaml generates textrels on 32-bit arches
# We can't do anything about it, but disabling it means that tests
# for OCaml-based packages won't fail on unexpected output
# bug #773226
- #if use arm || use ppc || use x86 ; then
+ if use arm || use ppc || use x86 ; then
append-ldflags "-Wl,-z,notext"
- #fi
+ fi
# Upstream build ignores LDFLAGS in several places.
sed -i -e 's/\(^MKDLL=.*\)/\1 $(LDFLAGS)/' \
@@ -76,10 +78,13 @@ src_install() {
dodoc Changes README.adoc
# Create envd entry for latex input files
if use latex ; then
- echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}/99ocamldoc"
- doenvd "${T}/99ocamldoc"
+ echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}"/99ocamldoc || die
+ doenvd "${T}"/99ocamldoc
fi
+
+ sed -i -e "s:lib:$(get_libdir):" "${T}"/ocaml.conf || die
+
# Install ocaml-rebuild portage set
insinto /usr/share/portage/config/sets
- doins "${FILESDIR}/ocaml.conf"
+ doins "${T}"/ocaml.conf
}
diff --git a/dev-lang/ocaml/ocaml-4.12.0-r1.ebuild b/dev-lang/ocaml/ocaml-4.12.0-r2.ebuild
index 137a6160e458..da99522c6e38 100644
--- a/dev-lang/ocaml/ocaml-4.12.0-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-4.12.0-r2.ebuild
@@ -23,13 +23,15 @@ PDEPEND="emacs? ( app-emacs/ocaml-mode )
src_prepare() {
default
+ cp "${FILESDIR}"/ocaml.conf "${T}" || die
+
# OCaml generates textrels on 32-bit arches
# We can't do anything about it, but disabling it means that tests
# for OCaml-based packages won't fail on unexpected output
# bug #773226
- #if use arm || use ppc || use x86 ; then
+ if use arm || use ppc || use x86 ; then
append-ldflags "-Wl,-z,notext"
- #fi
+ fi
# Upstream build ignores LDFLAGS in several places.
sed -i -e 's/\(^MKDLL=.*\)/\1 $(LDFLAGS)/' \
@@ -83,11 +85,13 @@ src_install() {
# Create envd entry for latex input files
if use latex ; then
- echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}/99ocamldoc" || die
- doenvd "${T}/99ocamldoc"
+ echo "TEXINPUTS=\"${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:\"" > "${T}"/99ocamldoc || die
+ doenvd "${T}"/99ocamldoc
fi
+ sed -i -e "s:lib:$(get_libdir):" "${T}"/ocaml.conf || die
+
# Install ocaml-rebuild portage set
insinto /usr/share/portage/config/sets
- doins "${FILESDIR}/ocaml.conf"
+ doins "${T}"/ocaml.conf
}