summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-wm/dwl/dwl-9999-r1.ebuild13
-rw-r--r--gui-wm/dwl/dwl-9999.ebuild13
2 files changed, 18 insertions, 8 deletions
diff --git a/gui-wm/dwl/dwl-9999-r1.ebuild b/gui-wm/dwl/dwl-9999-r1.ebuild
index dd4f5c714b7a..64c73b5b8ef2 100644
--- a/gui-wm/dwl/dwl-9999-r1.ebuild
+++ b/gui-wm/dwl/dwl-9999-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,12 @@ EAPI=8
inherit savedconfig toolchain-funcs
MY_P="${PN}-v${PV}"
-WLROOTS_SLOT="0/18"
+
+WLROOTS_DEP="
+ >=gui-libs/wlroots-0.18:=[libinput,session,X?]
+ <gui-libs/wlroots-0.19:=
+"
+
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://codeberg.org/dwl/dwl.git"
inherit git-r3
@@ -19,7 +24,7 @@ if [[ ${PV} == *9999* ]]; then
;;
9999-r1)
EGIT_BRANCH=wlroots-next
- WLROOTS_SLOT="0/9999"
+ WLROOTS_DEP="~gui-libs/wlroots-9999:=[libinput,session,X?]"
;;
esac
else
@@ -36,9 +41,9 @@ SLOT="0"
IUSE="X"
RDEPEND="
+ ${WLROOTS_DEP}
dev-libs/libinput:=
dev-libs/wayland
- gui-libs/wlroots:${WLROOTS_SLOT}[libinput,session,X?]
x11-libs/libxkbcommon
X? (
x11-libs/libxcb:=
diff --git a/gui-wm/dwl/dwl-9999.ebuild b/gui-wm/dwl/dwl-9999.ebuild
index 9597cd86dc6b..11f48b8e090b 100644
--- a/gui-wm/dwl/dwl-9999.ebuild
+++ b/gui-wm/dwl/dwl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,12 @@ EAPI=8
inherit savedconfig toolchain-funcs
MY_P="${PN}-v${PV}"
-WLROOTS_SLOT="0/17"
+
+WLROOTS_DEP="
+ >=gui-libs/wlroots-0.17:=[libinput,session,X?]
+ <gui-libs/wlroots-0.18:=
+"
+
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://codeberg.org/dwl/dwl.git"
inherit git-r3
@@ -19,7 +24,7 @@ if [[ ${PV} == *9999* ]]; then
;;
9999-r1)
EGIT_BRANCH=wlroots-next
- WLROOTS_SLOT="0/9999"
+ WLROOTS_DEP="~gui-libs/wlroots-9999:=[libinput,session,X?]"
;;
esac
else
@@ -36,9 +41,9 @@ SLOT="0"
IUSE="X"
RDEPEND="
+ ${WLROOTS_DEP}
dev-libs/libinput:=
dev-libs/wayland
- gui-libs/wlroots:${WLROOTS_SLOT}[libinput,session,X?]
x11-libs/libxkbcommon
X? (
x11-libs/libxcb:=