summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-apps/libkleo/files/libkleo-21.12.3-gcc-12.patch32
-rw-r--r--kde-apps/libkleo/libkleo-21.12.3.ebuild2
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-apps/libkleo/files/libkleo-21.12.3-gcc-12.patch b/kde-apps/libkleo/files/libkleo-21.12.3-gcc-12.patch
new file mode 100644
index 000000000000..64a62e8bbd6c
--- /dev/null
+++ b/kde-apps/libkleo/files/libkleo-21.12.3-gcc-12.patch
@@ -0,0 +1,32 @@
+From f290218a6fd4e2b849875f6d465eaa861ec02aff Mon Sep 17 00:00:00 2001
+From: Martin Liska <mliska@suse.cz>
+Date: Fri, 25 Mar 2022 14:40:37 +0100
+Subject: [PATCH] Include <iterator>.
+
+In order to fix:
+[ 16s] /home/abuild/rpmbuild/BUILD/libkleo-21.12.3/src/kleo/keyserverconfig.cpp:73:44: required from here
+[ 16s] /home/abuild/rpmbuild/BUILD/libkleo-21.12.3/src/utils/algorithm.h:35:30: error: no matching function for call to 'begin(QStringList&)'
+[ 16s] 35 | std::transform(std::begin(c), std::end(c), std::begin(c), op);
+[ 16s] | ~~~~~~~~~~^~~
+
+The change is documented here:
+https://gcc.gnu.org/gcc-12/porting_to.html#header-dep-changes
+---
+ src/utils/algorithm.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/utils/algorithm.h b/src/utils/algorithm.h
+index 6fb8669..1bcab2c 100644
+--- a/src/utils/algorithm.h
++++ b/src/utils/algorithm.h
+@@ -11,6 +11,7 @@
+ #pragma once
+
+ #include <algorithm>
++#include <iterator>
+
+ namespace Kleo
+ {
+--
+GitLab
+
diff --git a/kde-apps/libkleo/libkleo-21.12.3.ebuild b/kde-apps/libkleo/libkleo-21.12.3.ebuild
index 98950561d516..b758bb9f8720 100644
--- a/kde-apps/libkleo/libkleo-21.12.3.ebuild
+++ b/kde-apps/libkleo/libkleo-21.12.3.ebuild
@@ -36,6 +36,8 @@ DEPEND="${RDEPEND}
dev-libs/boost
"
+PATCHES=( "${FILESDIR}/${P}-gcc-12.patch" ) # bug 839921
+
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package fancyviewer KF5PimTextEdit)