summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.13-r1.ebuild42
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.14-r1.ebuild42
2 files changed, 84 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.13-r1.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.13-r1.ebuild
new file mode 100644
index 000000000000..93079328f2a5
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.13-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-wayland/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ >=gui-libs/eglexternalplatform-1.1-r1
+ media-libs/libglvnd
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_install() {
+ meson-multilib_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.14-r1.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.14-r1.ebuild
new file mode 100644
index 000000000000..93079328f2a5
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.14-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-wayland/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ >=gui-libs/eglexternalplatform-1.1-r1
+ media-libs/libglvnd
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_install() {
+ meson-multilib_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}