summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/python_qt_binding/Manifest2
-rw-r--r--dev-ros/python_qt_binding/files/var.patch31
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild20
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.5-r1.ebuild21
4 files changed, 0 insertions, 74 deletions
diff --git a/dev-ros/python_qt_binding/Manifest b/dev-ros/python_qt_binding/Manifest
index c467716f79a8..2365075a9aad 100644
--- a/dev-ros/python_qt_binding/Manifest
+++ b/dev-ros/python_qt_binding/Manifest
@@ -1,3 +1 @@
-DIST python_qt_binding-0.3.4.tar.gz 12255 BLAKE2B bc72aa806098d460e5b884bde7664f295399555d96e10b66791e59a26d1e61dd22aabecf9b40b5d14f61c2c906c18ff3fe2cd03de6108d7d9c2c649d553ab09d SHA512 df5fc2c6a744e66d0c03089e15ce4cfb3890d8fd67d826a3832d22cf99de235e18720c59f737c3ddacefb02dac5571d64042dd862c10ea4c44835063037eb533
-DIST python_qt_binding-0.3.5.tar.gz 12412 BLAKE2B ee2f2537bb1ddceb5cce0ca1963e042d10e5d011cffac25caba1a714c992d975413b7e1c4a23d5472567d4e214f482414dcfc56d499fcbcb0bd5559d7670b484 SHA512 a54ce90008d0893f236533cdda7d3520db264ba3e66b6edf18bac0d6e97975823e3900d1f265a7459813c823c9fc0bce7bb12570de1f8101b588954adeb073b4
DIST python_qt_binding-0.4.3.tar.gz 12632 BLAKE2B 1403602262a18ce359d153234bb01ff3a6a90e91f9f4a84ddcd0551723c04c493526f51b81f750c90f78005d2c5b78cf77396ecd3132f1c505038bad8639b63d SHA512 103f791a27f8e8dad668a63c0bfc96facd93cbb043541bd036355d62c787759724fe0d66788c587c3cb68486e6d2732039d7c27f567ed48f2ecf21ce98d275af
diff --git a/dev-ros/python_qt_binding/files/var.patch b/dev-ros/python_qt_binding/files/var.patch
deleted file mode 100644
index f0cd56d10a7e..000000000000
--- a/dev-ros/python_qt_binding/files/var.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 1b3000d2eccfad651b427de20028a4ca552e9ea7 Mon Sep 17 00:00:00 2001
-From: Hans Gaiser <h.gaiser@fizyr.com>
-Date: Mon, 29 Jul 2019 15:17:39 -0700
-Subject: [PATCH] Replace Qt variable in generated Makefile. (#64)
-
-* Replace Qt variable in generated Makefile.
-
-* use single quotes
----
- cmake/sip_configure.py | 9 +++++++++
- 1 file changed, 9 insertions(+)
-
-diff --git a/cmake/sip_configure.py b/cmake/sip_configure.py
-index 49eb866..ce084dd 100644
---- a/cmake/sip_configure.py
-+++ b/cmake/sip_configure.py
-@@ -145,5 +145,14 @@ def split_paths(paths):
- else:
- makefile.extra_cxxflags.append('-std=c++14')
-
-+# Finalise the Makefile, preparing it to be saved to disk
-+makefile.finalise()
-+
-+# Replace Qt variables from libraries
-+libs = makefile.LIBS.as_list()
-+for i in range(len(libs)):
-+ libs[i] = libs[i].replace('$$[QT_INSTALL_LIBS]', config.build_macros()['LIBDIR_QT'])
-+makefile.LIBS.set(libs)
-+
- # Generate the Makefile itself
- makefile.generate()
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild
deleted file mode 100644
index 6aed5cfe415e..000000000000
--- a/dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
-KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin
-
-DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.5-r1.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.5-r1.ebuild
deleted file mode 100644
index c4bda1c59580..000000000000
--- a/dev-ros/python_qt_binding/python_qt_binding-0.3.5-r1.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
-KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin
-
-DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/var.patch" )