summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.7.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 8d2a64ca8292..3ae37e90cf0f 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_6.6.0-1stretch_all.deb 21210 BLAKE2B 366c5d0d97e3e1f63e61bc6a8d7d05b621c226cff872c4f780b4b08aac8db9ebcbbe5e5c81f9a79f11e1fc9cedb8c42d86e69055fb5af2195f07c59347699eda SHA512 b410322239933539b685c65c1f85ecca28269adaf94d4521b4ee6d0780701889c6aaec4c01fdcdce1338277544d249c597ac9c697bdacdeb943c53fd6538d348
DIST puppetdb-termini_6.7.1-1stretch_all.deb 21284 BLAKE2B f56f9bfa97f711be08250cc525714af55b9defe2f12b17b2a5f3ec931d9f2f461f009bd0c3534eee848b45d3454752392479ae179695d27f42bc7e4747903dba SHA512 b03a3ebcc068ab7274abd7096821231dcafc1ce7064b6692f5834f28f3046905c855336c5aff4db1b031a2d06c616a75fa48860f45800bfc167c9045364bbcd4
+DIST puppetdb-termini_6.7.2-1stretch_all.deb 21298 BLAKE2B 4f4af664b45385487061c26051060d2fae668e80841e48a7a2db899769ca7cdad84bd7956fd1806526db307a42604bb3fa3e686d6c960a3c7c760286f39e794c SHA512 7e3279b4e82ddece9350399cd1579bb0297f235c5003c93dc37aa23ae81bd1efd83739de5fc2634cc0fccfd222e8eb0603c622acabdce968fa05252c5ae8747f
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.7.2.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.7.2.ebuild
new file mode 100644
index 000000000000..6d51b944dfdb
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.7.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}