summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.34.29.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 0d258acf2bd2..53ed89d37ad8 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.34.25.gh.tar.gz 2799069 BLAKE2B 1f1a09b6b4b915570a67ebb9374799bd9
DIST aws-cli-1.34.26.gh.tar.gz 2799245 BLAKE2B 99762018d1f78f89526522f6b75dae2711138e3c5e404e29a1527cce812195895e6e1e8f429f63db2532f4e756591195aeb0fcf506a545a45320f182af60882e SHA512 c816dfdcde58832b86da8645f5e38118783fa1e0c320aceaf25477b1c703a28636395bdf6addf0b32c0c6124361957459165a81dc53e06beda31786fea7206b7
DIST aws-cli-1.34.27.gh.tar.gz 2799479 BLAKE2B fc5a52b4d685476874e7833897eab963e6276a24f99fceb344feebf44dd2444ea3aa2c3d1c74d9e308d4aceec77e35d9992e7af92fb5d927af7187fab4ba57a0 SHA512 1ad22b63046963ffc6cba82e07503332ca8b6cca255b686910a9325f43f3595fc7d4076fb4681a0e8d2b731aee5664ef50bf49fa18bbdca4266e334945c70b10
DIST aws-cli-1.34.28.gh.tar.gz 2799902 BLAKE2B cea6b5779983c1609ae576c0a0bc5bc34ddd6bc882d12aa68cb00ab132035fcb2b8389f13785609a6e06f061f41ff884853166f3dd9ab7ad944a812844fd2a13 SHA512 b6575417584b7c1a25f8f0358fe029757f29bbeccb20be8054dc1036ef14fefbe37437fe6cabbfcfae7703edea3cfff5ebe7c597dadd92465762232b1b8a51b9
+DIST aws-cli-1.34.29.gh.tar.gz 2800945 BLAKE2B 93d9b41dfb2d80546f6cd601ff339053b6fef760bf9359d56b2d3835c1a8cca21146b492100db611c1bbe8601ad143dde0490b86d63eba7707141a5ca0c6aecb SHA512 9174fbc0e552d708916080b8b3d5b6b1e871332ac2a8b65b27091745b4537120d97c99ced878c861960f81b8368cb564a1fe573c9dc528c343b2100fc0ea6b08
diff --git a/app-admin/awscli/awscli-1.34.29.ebuild b/app-admin/awscli/awscli-1.34.29.ebuild
new file mode 100644
index 000000000000..599b9bd389b9
--- /dev/null
+++ b/app-admin/awscli/awscli-1.34.29.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}