summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/bits-atomic/Manifest2
-rw-r--r--dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild35
-rw-r--r--dev-haskell/bits-atomic/files/bits-atomic-0.1.3-ghc-8.patch9
-rw-r--r--dev-haskell/bits-atomic/metadata.xml41
-rw-r--r--profiles/package.mask1
5 files changed, 0 insertions, 88 deletions
diff --git a/dev-haskell/bits-atomic/Manifest b/dev-haskell/bits-atomic/Manifest
deleted file mode 100644
index fedb3f2de91d..000000000000
--- a/dev-haskell/bits-atomic/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST bits-atomic-0.1.3-gcc-5.patch 30907 BLAKE2B 135d495f914af645de82c4d3cd491460dba6fee5293a591f9e83ad07efd7b47cedf32a841557eca0a852690e9367c6fd7a0d6722d6212193c7188fe70d673d77 SHA512 0a40015f225325db3716ac0a17e33eef3f2042b72f933000a52734b103ea3e316a0242a0b75c90a31d0d4c31d33da8d32b07f7c067d79ade51df66ea75a3b19c
-DIST bits-atomic-0.1.3.tar.gz 7982 BLAKE2B 4ac1e6c808c30fb8ad59509aefb9dcb32f98023b31efb2eabf59ea94cbc681aa94219a8389179c7755dfb8ad944bcab122676aca361502d030c85d04c7a4f113 SHA512 e13c21c81ebc6cce2f85a184a572eb1647439f605985a8344ff219cc685c7d0adcf5d2433ea75fa1560a807e329cab23b548435adc0087e6294417eb7a65fbf1
diff --git a/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild b/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild
deleted file mode 100644
index 278b011fad91..000000000000
--- a/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.4.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Atomic bit operations on memory locations for low-level synchronization"
-HOMEPAGE="https://hackage.haskell.org/package/bits-atomic"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
- https://dev.gentoo.org/~slyfox/patches/${P}-gcc-5.patch"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( dev-haskell/hunit
- dev-haskell/quickcheck
- dev-haskell/test-framework
- dev-haskell/test-framework-hunit
- dev-haskell/test-framework-quickcheck2 )
-"
-
-PATCHES=(
- "${DISTDIR}"/${P}-gcc-5.patch
- "${FILESDIR}"/${P}-ghc-8.patch
-)
diff --git a/dev-haskell/bits-atomic/files/bits-atomic-0.1.3-ghc-8.patch b/dev-haskell/bits-atomic/files/bits-atomic-0.1.3-ghc-8.patch
deleted file mode 100644
index eb12edc2d4f3..000000000000
--- a/dev-haskell/bits-atomic/files/bits-atomic-0.1.3-ghc-8.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/test/test.hs b/test/test.hs
-index 38238b5..c3a99b0 100644
---- a/test/test.hs
-+++ b/test/test.hs
-@@ -35,3 +35,3 @@ testPattern = 0xdeadbeef
-
--type PolyTest = (AtomicBits a, Storable a, Integral a, Bounded a, Show a) => a -> Assertion
-+type PolyTest = forall a . (AtomicBits a, Storable a, Integral a, Bounded a, Show a) => a -> Assertion
-
diff --git a/dev-haskell/bits-atomic/metadata.xml b/dev-haskell/bits-atomic/metadata.xml
deleted file mode 100644
index d93ea74cbc2d..000000000000
--- a/dev-haskell/bits-atomic/metadata.xml
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- Atomic operations including CAS (compare-and-swap), fetch &amp; add and variants
- suitable for low-level shared-memory synchronization.
-
- The implementation is using GCC's builtin atomic operations (available in GCC &gt;=
- 4) in C wrappers called through the FFI. See these links for background:
-
- * GCC manual: &lt;https://gcc.gnu.org/onlinedocs/gcc/Atomic-Builtins.html&gt;
-
- * GCC wiki: &lt;https://gcc.gnu.org/wiki/Atomic&gt;
-
- /Portability/: This package is primarily developed on a Linux system, but
- should work wherever GCC &gt;= 4 is available. It has been confirmed as working
- on OSX. On Windows, it should work with Cygwin but currently fails for
- vanilla Haskell-Platform 2010.1.0.0 as it still packages GCC 3.x. An
- installer for updated versions of GCC is available at
- &lt;http://www.mingw.org/&gt; and should make this package work in connection with
- Haskell-Platform. Feedback on compatibility would be appreciated.
-
- /Testing:/ The following commands can be used to compile and run the test suite:
-
- &gt; cabal unpack bits-atomic &amp;&amp; cd bits-atomic-* # if not yet locally available
- &gt; cabal configure -ftest
- &gt; cabal build
- &gt; cabal test
-
- /Recent changes/:
-
- * 0.1.3: Documentation updates, especially on portability. No functional
- changes.
-
- * 0.1.2: Avoid using System.FilePath in Setup.hs to fix build failure on hackage
- </longdescription>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 06d0532e1c91..13082482e111 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -350,7 +350,6 @@ dev-haskell/biocore
dev-haskell/biofasta
dev-haskell/biosff
dev-haskell/bitarray
-dev-haskell/bits-atomic
# Hans de Graaff <graaff@gentoo.org> (2022-07-16)
# No longer supported upstream. Use a newer ruby version instead.