summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/googleapis-common-protos/Manifest1
-rw-r--r--dev-python/googleapis-common-protos/googleapis-common-protos-1.54.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/googleapis-common-protos/Manifest b/dev-python/googleapis-common-protos/Manifest
index eb3df5b9f268..23b4ce89b0d6 100644
--- a/dev-python/googleapis-common-protos/Manifest
+++ b/dev-python/googleapis-common-protos/Manifest
@@ -1 +1,2 @@
DIST googleapis-common-protos-1.53.0.tar.gz 106651 BLAKE2B a38ae93d0fe639bad571d74c9f2d011504cd82175e19aad27deda467676936c7df804ded50ee51544615609ce4fb6a6ec629fa175fbda7b2119c73747b6c58a7 SHA512 2ae8230b712ab6fc8328d3e3ba55ace28b9ba5fe3a300899b4a1f13d5d8b3bfd19eef9d1829747b57c56169351e4aa14380551d009fe6bd46e27aa22e7d3b9a5
+DIST googleapis-common-protos-1.54.0.tar.gz 112874 BLAKE2B 95d2429d8bf27299ff406d0a06f31b2b499f66533cf884a8ec77ed6defa10bdabd6460232265efc9606e5f890ab14c571a0240e842fbdf7117ff3d7bff5ef28d SHA512 535cf6e4e5331a99232cb3eec1bc56676fcf87c522bd5b06f3452c7b22abd51479f3e4c69c8654bba4d789e8267360e11573d357ac90bb63854281e227eb8bc6
diff --git a/dev-python/googleapis-common-protos/googleapis-common-protos-1.54.0.ebuild b/dev-python/googleapis-common-protos/googleapis-common-protos-1.54.0.ebuild
new file mode 100644
index 000000000000..e33bff07b4b9
--- /dev/null
+++ b/dev-python/googleapis-common-protos/googleapis-common-protos-1.54.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="python classes generated from the common protos in the googleapis repository"
+HOMEPAGE="https://pypi.org/project/googleapis-common-protos/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.12.0[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}
+
+# no tests as this is all generated code