summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/mesa/mesa-9999.ebuild8
-rw-r--r--media-libs/mesa/metadata.xml1
2 files changed, 6 insertions, 3 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 93e5bd61047d..2a6e279fd590 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -40,9 +40,9 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm
- +nptl opencl osmesa pax_kernel openmax pic selinux vaapi valgrind vdpau
- vulkan wayland xvmc xa"
+ bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 unwind
+ +llvm +nptl opencl osmesa pax_kernel openmax pic selinux vaapi valgrind
+ vdpau vulkan wayland xvmc xa"
REQUIRED_USE="
d3d9? ( dri3 gallium )
@@ -93,6 +93,7 @@ RDEPEND="
>=x11-libs/libXxf86vm-1.1.3:=[${MULTILIB_USEDEP}]
>=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
+ unwind? ( sys-libs/libunwind )
llvm? (
video_cards_radeonsi? (
virtual/libelf:0=[${MULTILIB_USEDEP}]
@@ -313,6 +314,7 @@ multilib_src_configure() {
$(use_enable gles1) \
$(use_enable gles2) \
$(use_enable nptl glx-tls) \
+ $(use_enable unwind libunwind) \
--enable-valgrind=$(usex valgrind auto no) \
--enable-llvm-shared-libs \
--with-dri-drivers=${DRI_DRIVERS} \
diff --git a/media-libs/mesa/metadata.xml b/media-libs/mesa/metadata.xml
index 054cb72a186d..602443d24979 100644
--- a/media-libs/mesa/metadata.xml
+++ b/media-libs/mesa/metadata.xml
@@ -17,6 +17,7 @@
<flag name="gles1">Enable GLESv1 support.</flag>
<flag name="gles2">Enable GLESv2 support.</flag>
<flag name="libressl">Use <pkg>dev-libs/libressl</pkg> for low level sha1 utility functions.</flag>
+ <flag name="libunwind">Add support for stack trace unwinding and function name resolution</flag>
<flag name="llvm">Enable LLVM backend for Gallium3D.</flag>
<flag name="nettle">Use <pkg>dev-libs/nettle</pkg> for low level sha1 utility functions.</flag>
<flag name="opencl">Enable the Clover Gallium OpenCL state tracker.</flag>