summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/ekeyd/files/ekeyd-1.1.5-makefile-lua-libs.patch')
-rw-r--r--app-crypt/ekeyd/files/ekeyd-1.1.5-makefile-lua-libs.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/app-crypt/ekeyd/files/ekeyd-1.1.5-makefile-lua-libs.patch b/app-crypt/ekeyd/files/ekeyd-1.1.5-makefile-lua-libs.patch
new file mode 100644
index 000000000000..7a929bdb64c0
--- /dev/null
+++ b/app-crypt/ekeyd/files/ekeyd-1.1.5-makefile-lua-libs.patch
@@ -0,0 +1,15 @@
+If LUA_V is passed directly to LIBS it ends up being expanded to an empty
+string at link time.
+
+--- a/host/Makefile
++++ b/host/Makefile
+@@ -111,7 +111,8 @@
+ CFLAGS += '-DEKEYD_VERSION_S=""$(EKEYD_VERSION_S)""'
+ CFLAGS += $(EXTRA_CFLAGS)
+
+-LIBS += -llua -lm $(LIBDL)
++LUA_LIBS += -llua$(LUA_V) -lm
++LIBS += $(LUA_LIBS) $(LIBDL)
+ LDFLAGS += $(LIBDIRS)
+
+